1

What is the configuration setting to not show icons next to menu dropdown items for KDE applications installed in Ubuntu?

Gnome applications do not display an icon next to dropdown menu items. However, KDE applications installed in Ubuntu do display an icon next to dropdown menu items.

Here is an example of a KDE application. Notice the icons next to the menu items.

KDE Menu Dropdown with Icons

Here is an example of a Gnome application. Notice there are no icons next to the menu items.

enter image description here

Is there an appropriate entry in /usr/share/kde4/config/kdeglobals (or other configuration file) to achieve this result?

I have unsuccessfully tried the following entries in kdeglobals.

[KDE]
ShowIconsInMenuItems=false
ShowIconsOnPushButtons=false

If you can't identify the correct configuration file and entry, steps using KDE System Settings (installed via the systemsettings package) will also suffice.

1

There is an option for that in KDE's systemsettings, in

Application Appearence > Style > Fine Tuning
  • Thank you for this suggestion. Under "Fine Tuning" I found "Show Icons on buttons" and "Show Icons in menus". Both were unchecked (false), as configured in kdeglobals. I changed "Main toolbar text" to "Text Only" but this only removed icons from the in-window toolbar-- not what I wanted. Changing "Secondary toolbar text" to "Text Only" had no effect. Trying different options for "Menubar style" had no effect. With all of these options, icons still appeared in the Unity global menu-bar drop-downs. (Also these changes had no effect on Unity's Locally Integrated Menus, either). – PJ Singh May 12 '15 at 1:39
  • Looks like the only action left is to file a bug report against unity or whatever package is responsible for menus. – int_ua May 12 '15 at 7:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.