0

I am trying to install MathGeoLib in Ubuntu 14.04 but I have a problem as the instructions I have are for installation on a MAC. I have installed git and cmake.

First I used git to clone the project:

git clone https://github.com/juj/MathGeoLib.git

Then I selected the linux directory in it:

cd MathGeoLib/linux

then I tried to run:

./filenames

where filenames are the files in that directory (I did that as I didn't know which one was the correct).

Then based on the instructions for MAC I should run:

make -j4
sudo make install

But I can't install it as I had guessed with these instructions. What should I do? Can anyone explain? As it seems to me it must be a pretty easy procedure for someone that knows how to use CMake.

1 Answer 1

2

The distribution appears to use the cmake build system. A suitable minimal out-of-tree build procedure would be something like

mkdir Build && cd Build
cmake ..

Then

make
sudo make install
9
  • Yes indeed it uses cmake but as that is the first time I try to use something like that your instructions seem to me a little vague as I have no idea how to implement them. Thank you for your answer though. :P
    – Adam
    May 8, 2015 at 1:09
  • Did you try the commands? they should work exactly as posted, unless the default installation options don't work for you: you can see additional options by running cmake -LH .. or cmake -LAH .. from the Build directory. May 11, 2015 at 2:04
  • Yes I did. They don't work. I am trying to install it and I can't find a way! I have tried everything I could find.
    – Adam
    May 11, 2015 at 2:05
  • What part exactly doesn't work? what happens? are there any error messages? May 11, 2015 at 2:08
  • There is no install file. Also I don't understand where should I run make? In the Build directory?
    – Adam
    May 11, 2015 at 2:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .