1

When I try to open the Software Center, I get a message saying "Could not determine the package name."

I am a new Linux user, detailed help is most appreciated!

2
  • 1
    Which Ubuntu are you running?
    – Ron
    May 8, 2015 at 4:16
  • 12.04 LTS 64 bit May 8, 2015 at 15:49

4 Answers 4

0

Run the following in a terminal:

sudo rm /var/lib/apt/lists/*
sudo apt-get update
1
0

The solution that I have found to solve this bug, after many months of research, and many misleading information found on the web/google/blogs/forums is very simple, but difficult to understand for newbies and non-coders.

CAUTION: The Internet is full of 'false solution' (ie. or very case singular) to software-center bug affecting ubuntu users, and that lead to make your system even more corrupted and buggier than before, so please do take your time to understand what you are intending to "sudo" with or you will be in trouble.

After reading around quite a bit on several similar and somewhat related bug reports, the following 2 steps solved it for me (or seem to have solved it for all the systems I could identify with same crash log - which is also misleading - caution reading logs!).

Does not need to purge software-center or upgrade distribution or worst: DO NOT REINSTALL YOUR SYSTEM! Does not have to do with dbus or proxy or hardware problems, these are just side effects.

I diagnosed the problem as a 'pip' bug or 'pip configuration' corruption and its consequence on python subsystem.

So I targeted it as the result of a python 'pip' installation bug after a wrong 'pip' installation of a non standard package repository.

The solution is in part found for the 'pip' problem here:

REF: https://github.com/pypa/pip/issues/2686 User: jayachar88 commented on Apr 15, 2015

The solution is very simple at the end, just do this:

$ sudo python -m pip install --upgrade --force setuptools
$ sudo python -m pip install --upgrade --force pip

Not only does this solves python exception error with pip upgrade, but also a greater bug of Ubuntu community, which is the software-center crash bug.

Cheers!

0

Maybe You removed it by mistake reinstall it

open terminal :

sudo apt-get update

sudo apt-get install software-center
3
  • it told me the same May 8, 2015 at 15:44
  • Open Terminal and the this command ` software-center ` if you got any error share it
    – Mike
    May 8, 2015 at 16:53
  • it gave me several lines and opened the software center then closed instantly. The last line was "AttributeError: 'NoneType' object has no attribute 'contains' May 8, 2015 at 22:34
0

Open terminal use this command to remove software center

sudo apt-get remove software-center
sudo apt-get update
sudo apt-get install software-center
1
  • when I wrote sudo apt-get update i got ''E: Malformed line 6 in source list /etc/apt/sources.list (dist parse) E: The list of sources could not be read. May 9, 2015 at 13:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.