3

I occasionally need to VPN to my work's network which is an all Windows shop. The VPN protocol we use is PPTP.

I have been running Ubuntu 14.04/14.10 (Unity) for about a year, and did not have any trouble setting up the PPTP VPN using the standard Network Manager. I recently decided to "nuke and pave" my OS, and start fresh with Ubuntu MATE 15.04. The problem is that I cannot get the VPN to connect to the work network from Ubuntu MATE.

I can confirm that the VPN configuration is EXACTLY the same as it was in my previous Ubuntu versions; in fact, I can live boot to Ubuntu 14.04 (from DVD) and get the VPN to connect using the same configuration, but for some reason it doesn't work on this fresh Ubuntu MATE 15.04 install.

I haven’t tried yet on a live boot of Ubuntu 15.04 (Unity), but I am planning to do that to see if it is a 15.04 problem or a MATE problem.

What am I missing? I've made sure ppp and all the libraries it is dependent on are installed. Is there a configuration switch somewhere in MATE that is causing issues, or am I missing some required libraries?

EDIT: I can now confirm that pptp vpn does not work for me in Unity 15.04, either. The notification I get when the connection fails states 'The VPN connection failed because the VPN service returned invalid configuration.' Even though, again, that same configuration works fine in 14.04/14.10.

EDIT 2: I've submitted a bug report over at Launchpad (https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1452941). Looks like I am not the only person with this problem-- the bug has been confirmed by others.

3

This seems to be a known bug: https://bugzilla.gnome.org/show_bug.cgi?id=733296

There are hints as how to work-around that in the comments, starting at comment #4

  • Thanks for the link, solsTiCe. After looking at some of the recommendations in that link you provided, I found a solution. In 14.04/14.10, I originally had had to set up an IPV4 Route to get the PPTP VPN to work. In 15.04, deleting that Route from the GUI configuration settings solved the problem. After deleting that route, the VPN is able to connect! – dagrha May 20 '15 at 4:39
  • Can you post the solution here, please. – OHLÁLÁ Dec 15 '15 at 19:32
3

I had a similar experience when switching to 15.04. For me, the fix was to remove the gateway from the routes. In 14.04 I used the destination IP (the gateway) as the gateway in a static route. try 0.0.0.0 or just remove it from the route so you just have an address and a netmask.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.