3

This question already has an answer here:

I have tried the approach that I have used before on earlier releases of Ubuntu but on 15.04 I have found that the following commands are not working.

sudo xhost +SI:localuser:lightdm

sudo su lightdm -s /bin/bash

gsettings set com.canonical.unity-greeter draw-grid false

When I run the last command I get the following:

(process:5354): dconf-WARNING **: failed to commit changes to dconf: Error spawning command line 'dbus-launch --autolaunch=1af246dec6324e1ca014e1c3c06da71c --binary-syntax --close-stderr': Child process exited with code 1

Can anybody suggest what I'm doing wrong, or ways that I could diagnose what is failing?

Cheers

marked as duplicate by Community Mar 15 '16 at 10:49

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

3
  1. Install Ubuntu Tweak. It still works although it hasn't been updated for a while. You can download the deb package from here: https://launchpad.net/ubuntu-tweak
  2. Start Ubuntu Tweak, go to Tweaks > Startup > Login Settings. There you should be able to "Unlock" Root privileges and select some LDM Preferences like "Draw Grid".

enter image description here

  • COmmand line is good but GUI is easier and has done the trick. – Mitty May 7 '15 at 12:48
  • What GTK theme are you using? – Waldir Leoncio Mar 12 '16 at 6:46
  • 1
    @Waldir Leoncio, it's Vertex Light – Sadi Mar 12 '16 at 10:27
-1

According to the (German) Wiki of ubuntuusers.de, starting from Ubuntu 12.04 you need to use the dconf-editor GUI tool. You start it just as you did with gsettings set before: Giv the 'lightdm' user account access to your GUI (xhost), switch to that user account (su) and start dconf-editor

xhost +SI:localuser:lightdm
sudo su lightdm -s /bin/bash
dconf-editor
  • this results in the error that prompted the question – d3vid Sep 7 '15 at 10:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.