Unable to install GRUB in /dev/sdb

Unfortunately (as you can see) I cannot install grub. I have tried /dev/sda as well.

Here is my partitioning schema:

My partitioning schema

Troubleshooting + problems:

  • Installed Windows 8 to logical partition (somehow got marked "active")
  • Found Metro BCD to be lacking (takes forever to load, doesn't have other non-Windows OSs)
  • Installed EasyBCD, couldn't detect the BCD. So I made my Win7 primary the active
  • Something stuffed up in its BCD, it redirects to Win8 BCD, so I want to make GRUB default
  • 11.04 GRUB can't be activated for some reason

So I download 11.10 x64 Beta on my old laptop, push it to a USB, and attempt to install it on my other hard-drive.

Then I get the first mentioned error. I have also tried (before and after) running sudo grub-install manually on the respective drives, to no avail.

When I now attempt to boot to the hard-disk, I get PXE boot.

Please suggest further troubleshooting steps (e.g. LILO?).

  • Boot-info output: pastebin.com/6mtHBeGd – A T Sep 19 '11 at 5:08
  • Are you attempting to use btrfs for your / ? – Jeremy Bicha Sep 19 '11 at 5:48
  • Yes, I am indeed. – A T Sep 19 '11 at 5:58
  • Currently attempting the chroot fix from help.ubuntu.com/community/Grub2#ChRoot Received this error: /usr/sbin/grub-setup: warn: Sector 32 is already in use by FlexNet; avoiding it. This software may cause boot or other problems in future. Please ask its authors not to store data in the boot track. Installation finished. No error reported. Now rebooting. – A T Sep 19 '11 at 6:08
  • 2
    @A T, it says right there that the installation completed with no errors. It is just warning you that it has noticed you have a dumb windows program installed that is illegally using part of the boot track where grub normally goes, but grub is working around that. – psusi Sep 19 '11 at 13:41

I got the same error message. The installation configuration that led to this message is as follows:

/dev/sda1        ntfs :windows partition
/dev/sda2        ntfs :windows partition
/dev/sda3        ntfs :windows partition

/dev/sda5             :swap  partition 
/dev/sda6        ext4 :/     partition
/dev/sda7        ext4 :/home partition
/dev/sda8        ext2 :/boot partition

So, what worked -after lots of tests- is the configuration where I have changed the ext2 format of the /boot partition (/dev/sda8) to the ext4 format. I don't know if the problem was really in that point but at last it worked. I hope this will be helpful.


I don't believe grub reliably supports booting a btrfs partition, you'll either have to use a separate ext4 formatted /boot or just use a ext4 /.

I think trying to use grub with a btrfs / works in some cases but not others. It's not very well tested yet.

  • Hmm... is there a bootloader which supports BTRFS? – A T Sep 21 '11 at 6:06
  • GRUB2 (what Ubuntu uses) partially supports btrfs but btrfs is not really a good choice to use yet. You'll probably get better performance from the recommended ext4. – Jeremy Bicha Sep 22 '11 at 5:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.