3

I recently upgraded from Ubuntu 14.04 to Ubuntu 15.04. The upgrade went fine, except that now audio plays from the headphones and the speaker at the same time.

My speakers are plugged into the motherboard's green audio jack while the headphone jack is integrated into the front of my computer case. In the sound settings, there are 3 channels: Digital Output, Headphones, and Line Out. However, changing the audio on either Headphones or Line Out affects both the speaker volume and the headphone volume.

On Ubuntu 14.04, the channels had been Headphones, Digital Output, and Analog Output. Changing Analog Output did not affect Headphones and vice versa. Additionally, when I plugged in headphones, it automatically muted the speakers.

I am running on AMD hardware. Gigabyte GA 970a-DS3P, AMD FX-6300, Sapphire Radeon R7 240. The audio is built into the motherboard.

One difference is that I installed Ubuntu 15.04 in UEFI mode, whereas I had installed Ubuntu 14.04 in BIOS compatibility mode.

Additionally, because of a quirk in the motherboard, I turned off IOMMU in the BIOS settings. However, I did this in both 15.04 and 14.04, so I don't think this is the problem.

2
  • I have the same problem, and also a GA-970A-DS3P, but I'm on Ubuntu 14.04 (IOMMU is off, but I didn't turn it off myself: it was already off when I got the PC). So I'm a bit surprised that it worked for you in 14.04. What kernel version were you using? I'm on 3.16.0-37.
    – mardy
    May 21, 2015 at 11:59
  • For the record, I filed bugs.launchpad.net/bugs/1457476
    – mardy
    May 21, 2015 at 13:11

2 Answers 2

4

This worked for me:

sudo echo "options snd-hda-intel model=generic" \
   >> /etc/modprobe.d/alsa-base.conf

and reboot your PC. For improving the out-of-the-box experience in Ubuntu, I filed bug 1457476, let's hope that this can be fixed once and for all.

1
  • Works greatly. And I'm not using a notebook.
    – fotanus
    Jun 11, 2015 at 1:55
0

Try using Alsa mixer and turning down the device that you're not using

Just type alsamixer in a terminal, hope this helps

3
  • This actually works, but I'd really like automute to work. That is, whenever I plug in headphones, the speakers are automatically muted.
    – Cybran
    May 8, 2015 at 15:51
  • Some speakers have a headphone jack built into it try using that one instead.
    – user389450
    May 8, 2015 at 18:49
  • "automute" is a switch to activate in alsamixer (at least on my pc )
    – laugeo
    May 8, 2015 at 19:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.