3

I'm running Plex Media Server. All my media files are on an external NTFS drive. The external drive mounts, I can browse the files in it, Plex Media Manager can see the external USB drive, but Plex Media Manager doesn't see any of the directories or files inside the external NTFS drive. I know others have asked this question before. I even found a solution on here earlier today just before I reconfigured my machine and lost my web history and now I can't find it. Please help.

  • okay I added plex to the plugdev group and did chmod 777 /media/<user>/ so now plex media manager can browse directories and add files to libraries, and I can see my media files in the plex channel on my roku box but I get a "media unavailable" error any time I try to play anything. Now what's up? It'd be great if somebody answered me. That's what this place is for, right? – Dru Smith May 10 '15 at 3:18
  • Okay Plex Media Manager can see my directories and add files to my library. My port's forwarded in my router so my Plex server can be seen outside my network (which I never had to do in Windows) the Plex app on my Roku box can see everything I've put in my libraries so far. I click to play one of the files and... it still can't play anything. "Video Unavailable: We're unable to play this video. Make sure the server is running and has access to this video.) – Dru Smith May 11 '15 at 2:17
2

Press ctrl+alt+t to open a terminal

Add Plex user to the plugdev group by entering "sudo gpasswd -a plex plugdev'"

right-click your external drive in the directory browser and go to properties to get its location

in the terminal enter "sudo chmod 777 "external drive location; ie media/computername"

right-click your Plex media folder on your external drive and copy the location

In the terminal enter "sudo chmod -R 777 "Plex media folder location; ie media/computername/ntfsdrivevolumename"

Call your ISP and have them help you turn on port forwarding to 32400 in your router. It's not that hard

If you can see your NTFS drive in your launcher it's already mounted. Ignore all the "tech help" telling you how to mount your NTFS drive.

  • 1
    Thanks for this answer. This was the solution to my problem. Actually simpler. Just: sudo gpasswd -a plex plugdev then sudo service plexmediaserver restart – GavinR Aug 30 '15 at 0:31
  • Just in case anyone wants to know what they are opening themselves up to, plug dev is the group which allows access to all external drives. Also, chmod 777 is complete overkill. Plex needs read access and that's it – Kolob Canyon Dec 30 '16 at 22:27
  • This solved my problem. What is plugdev though and why is it important to add plex to that group? – Hatefiend May 25 at 6:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.