1

A few days ago I installed Kubuntu 15.04 on my laptop. in first day I had no problem using WiFi at home but in my office I have no WiFi and I have to use a wired Ethernet cable to connect to the Internet and Kubuntu couldn't connect to wired connection! I searched and found this solution: adding two line of following commands to the /etc/network/interfaces file:

auto eth0
iface eth0 inet dhcp

and my problem with wired connection solved!

but a new problem was born! after this, my WiFi disconnects every time after a few minutes! and when I remove that code it will be OK!

can anyone tell me how I can have WiFi and wired Internet together?

  • you want to connect both wifi and ethernet to internet at the same time? – Ron May 6 '15 at 16:31
  • @Ron No! I want to connect to both of them separately! but without adding and removing that two lines of commands every time I switch between them – Mahdi Aryayi May 6 '15 at 16:37
0

You do not need to edit /etc/network/interfaces.

When you connect to a wired network, just disable wireless in Network Manager. And wired network card will receive an ip address by dhcp. It should work this way.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.