6

I've bean using Ubuntu, Xubuntu and recently Lubuntu on my desktop and laptop without problems.

I have just installed Lubuntu 15.04 on an old HP nx9005 laptop and it works fine, but it doesn't shut down properly. In fact, it shuts down but doesn't power off.

I've tried many solutions that were suggested on forums with no results. By the GUI shut down command or by sudo init 0 or sudo shutdown -P gives me the same results: It shuts down but doesn't power off.

The two last lines are:

OK Reached target shutdown  
(number) reboot: Power down  

and doesn't trigger power off. The reboot command works fine.
I have tried editing the /etc/default/grub adding

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" acpi=force apm=power_off

or

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash reboot=bios"

or

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash reboot=pci

or

GRUB_CMDLINE_LINUX="acpi_osi=\"Linux\""

or

GRUB_CMLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux"

with no improvements. The power button has no action and computer doesn't enter on suspend mode. Any suggestions?

3
  • Did you try to update bios? It may help to solve this issue. – Pilot6 May 9 '15 at 15:40
  • Yes I did. Updated to the last delivered by HP (KA.M1.60) – Luiz Alberto Megahertz May 13 '15 at 15:35
  • I am experiencing (nearly) the same problem, the only difference is that the last lines that are shown in my case are '[OK] Reached target Shutdown.', '[OK] Reached target Final Step.' and 'Starting Power-Off...'. I have a fresh install of Lubuntu 18.04 running on an Acer TravelMate 4501 LCi. I also tried the solution in the update-section explained by xtrchessreal, but it did not solve the problem. – Rantanplan Oct 27 '18 at 16:41
2

First this is bug #1464917:

If you think this bug is affecting you please report it to the bug link above, thank you.

Update:

There has been a development as a work around to this bug. It seems to be related to the swap file usage/management. Adam (from the bug link above) points out that if you turn your swap off, wait for it to process, before you shutdown the hang never happens. When you are ready to shutdown your machine, open a terminal window and type;

sudo swapoff -a

Wait for the command to process and give your prompt back then you should be able to perform normal shutdown. This is working for many including me.

end update

If the shutdown or reboot has hanged with this message Reached target Shutdown

Try Sysrq

  1. Hold down the Alt and SysRq (Print Screen) keys.
  2. While holding those down, type the following keys in order, several seconds apart: REISUB
  3. Computer should reboot.

You can also try the following after it hangs.

see if you can login tty1 and reboot

  1. Press Ctrl+Alt+F1 or Ctrl+Alt+F2 or Ctrl+Alt+F3 ...
  2. Write your username (lowercase, the name of the user folder in /home) and hit Enter
  3. Write your password (nothing will appear) and hit Enter

If your password and username are correct, you are now logged in.

If that fails try Ctrl+Alt+Del a couple times at that point in the tty1 screen

You might see a message that states the machine is going to reboot and then it should do just that after a minute or so.

Its better than a hard boot - until its fixed

In the bug notes it is reported that you can upgrade to Vivid-Proposed and it fixes the issue but some still see this after that upgrade. It might be worth a shot.

Btw the same bug affects me and I have not tried the upgrade yet but the steps I listed do work.

1
  • The link to the bug description is helpful for beginners like me. It described how to produce a shut-down log. Thanks for the link! – Rantanplan Oct 27 '18 at 17:29
0

I have Lubuntu 16.04.1 LTS

STEPS I DID FOR SOLVE

  • Press CTRL + ALT and T
  • In terminal paste sudo xedit /etc/modprobe.d/blacklist.conf
  • Write your user password
  • In the bottom of the windows add:

blacklist dw_dmac blacklist dw_dmac_core

  • Save and Quit
  • I did Follow step, but don't know if is neccesary: In the same terminal add: sudo update-grub
  • Reboot once (maybe could keep with issue, force reboot) Thats It. I Did it and the PC now colud PowerOff/Reboot/Suspend and everything.

NOTICE: For this to work you will need to eraser quite splash in the Grub Steps for this:

  • Press CTRL + ALT and T (open the terminal)
  • Paste this sudo xedit /etc/default/grub
  • Write your user password
  • In the line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" eraser quiet splash
  • Save and Quit
  • In terminal paste sudo update-grub

Notes: This work for ASER E-11 with previous Windows8.1 and now with Lubuntu 16.04.1 LTS.

Cons: In the Start or ShutDown the computer will show only console, but It'll works.

2
  • Please do not repost answers to multiple questions. If a question is solved by the same answer, then please mark those questions as duplicates instead. – Thomas Ward Dec 25 '16 at 16:03
  • @thomasward Persons who ask, have differents devices and situations, it's impossible with one marked questions solve all the similarities problems. Because of this I had chosen several questions who may be solve with my solution. – Luigi Lopez Dec 26 '16 at 2:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.