3

since the kernel upgrade to 4.0.1, because I had a version 3.1x, when you update the driver rtl8192eu not work for me, I get the following error

make [1]:  [_module_ / home / kevin / Desktop / install_folder / driver / rtl8192EU_linux_v4.2.2_7585.20130524] Error 2
make [1]: Leaving directory '/usr/src/linux-headers-4.0.1-040001-generic'
Makefile: 1043: recipe for target 'modules' failed
make:  [modules] Error 2

Compile driver make mistake: 2

Please check mistake Mesg

I tried to go back to the kernel version 3.1x but the problem persists you could do, not much information about this device chipset is 0bda: 818b

otherwise when compiling the 4.0.1 kernel drivers looking in the menuconfig meeting almost every family realtek drivers 8192ex, 8192eu least, is why? Please I need help I've been almost a week with this

the end of the log output (not copy everything because they are almost 500 lines) is as follows

cc1: some errors as warnings Being Treated
make [2]: [/home/kevin/Escritorio/install_folder/driver/rtl8192EU_linux_v4.2.2_7585.20130524/os_dep/li$
make [1]:  [_module_ / home / kevin / Desktop / install_folder / driver / rtl8192EU_linux_v4.2.2_7585.20130524] $
make:  [modules] Error 2

I need help

1

The procedure described above fails for new kernels (>4.3)

For me it worked fine with as below:

uname -r
4.8.10-040810-generic # output of uname -r

Download the .zip folder from https://github.com/Mange/rtl8192eu-linux-driver.git and expand it

cd  /path_to_the_driver_folder/rtl8192eu-linux-driver-master/
make
sudo make install
sudo depmod -a
sudo modprobe 8182eu

You may need to install some packages (linux-headers-generic build-essential dkms..)

You can also patch using the procedure described on the downloading page : https://github.com/Mange/rtl8192eu-linux-driver.git

For the next arriving kernel linux-4.9 (today = December, 2016), it works too but, in my hands,only after unplugging and re-plugging the device.

| improve this answer | |
-1

I also had this problem, but I found a solution, in this topic: https://forum.ubuntu-nl.org/index.php?topic=86081.25

In Ubuntu 15.04 I had to do the following:

Install this .deb file:
http://users.telenet.be/x86_64/Debian/dkms_rtl8192eu_4.3.1.1.11320.20140505_all.deb

Edit the file:

sudo gedit /usr/src/rtl8192eu-4.3.1.1.11320.20140505/Makefile

And add the following line: EXTRA_CFLAGS += -Wno-date-time

For example:

    EXTRA_CFLAGS += -Wno-unused-variable
    EXTRA_CFLAGS += -Wno-unused-value
    EXTRA_CFLAGS += -Wno-unused-label
    EXTRA_CFLAGS += -Wno-unused-parameter
    EXTRA_CFLAGS += -Wno-unused-function
    EXTRA_CFLAGS += -Wno-unused
    EXTRA_CFLAGS += -Wno-date-time

    #EXTRA_CFLAGS += -Wno-uninitialized

Save the file, and run this command:

sudo dkms autoinstall

Reboot and your wireless internet will work!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.