5

After opening TexStudio I got a message to update from version 2.8.4 to 2.9.4. After downloading the needed package, Ubuntu Software Center opens and it says that:

Breaks in the package texstudio-dbg dependency texstudio(=2.8.4+debian-3)

What can I do?

3

1st, read this:

Linux

We recommend that you first try to install TeXstudio from the repository of your distribution. Only if TeXstudio is not available there, use the following pre-packaged versions.

texstudio-dbg 2.8.4 needs texstudio 2.8.4, but you installed 2.9.4

Normally you do not need debug packages.


2nd, if you insist on 2.9.4, use the following steps:

  1. Remove the texstudio-dbg

    sudo apt-get remove texstudio-dbg
    
  2. Install your .deb file again:

    sudo dpkg -i texstudio_2.9.4_amd64.deb
    
  • Does this get rid of user settings like colour themes etc? – LondonRob Jan 16 '18 at 16:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.