2

Running Ubuntu GNOME and just upgraded to 15.04. I'm having trouble importing .mp3 files into Rhythmbox. Whenever I try and select my ~/Music/ folder that has the .mp3 files, I can just see the files but grayed out. I've tried dragging one of the files into the music playing area, but it just tells me that

Problem occurred without error being set. This is a bug in Rhythmbox
or GStreamer.

I've installed the ubuntu-restricted-extras package the gstreamers packages as well.

I'm happy to post the contents of my Rhythmbox plugins folder if that will help.

Thanks.

Update

I no longer run Ubuntu GNOME and have no way of verifying what the correct answer to my question is. It appears that there's been some good answers given in the answer section. So, I'm going to mark the one that looks most correct to me. Mods: please let me know if there's a better thing to do here.

  • 1
    I have a similar problem. The software is just funny. I can put mp3 files in other folders and it works fine. I renamed the ~/Music folder and it works fine. It seems that all folders named Music are not working. – user479213 Dec 7 '15 at 5:23
  • I think I figured out the problem. The software seems use a very special configuration for the Music folder. You can first locate the mp3 file you want to import and check the copy files that are outside the music library which means the music folder and you click the import. Then you will find that in the Music folder there is a folder been created. In the format like the ~/Music/OMI/Cheerleader(Remixes)/01 - Cheerleader.mp3 – user479213 Dec 7 '15 at 5:31
1

An update. The gstreamer package nowadays looks like it is gstreamer1.0 instead of gstreamer0.10. Then I had to follow the trick posted by Mehrotra, and it worked. The new xml list did indeed work!

What kind of bizarre bug is this related to Rhythmbox, and nobody takes care of it?

1

Install gstreamer0.10-fluendo-mp3

sudo apt-get install gstreamer0.10-fluendo-mp3

and:

sudo apt-get install gstreamer0.10-plugins-bad
sudo apt-get install gstreamer0.10-plugins-bad-multiverse
sudo apt-get install gstreamer0.10-plugins-base
sudo apt-get install gstreamer0.10-plugins-good
sudo apt-get install gstreamer0.10-plugins-ugly
  • I've already installed most of those packages too it seems. – gr1zzly be4r May 7 '15 at 11:58
  • i have same problem but you answer didnt help, those packages are already installed – Edward Torvalds Jun 26 '15 at 14:17
1

It could be due to the permissions on the folder where your music is kept.

I used chmod -R 777 FolderName where my music is stored and then Rhythmbox imported my tracks correctly.

1

I had a similar problem of no music imported or playable which began when Rhythmbox tried to import my music before the mp3 codecs were loaded. Having subsequently loaded the correct codecs, my solution was to close Rhythmbox, then open the Files browser, selecting Show Hidden Files from the View drop down, then clicking through the folders .local, share, rhythmbox,then right-clicking on the rhythmdb.xml database file and selecting rename to rhythmdb.bakxml and then restarting Rhythmbox which immediately began importing all the files from my default music folder. Rhythmbox created a brand new rhythmdb.xml file on its own and now all my mp3 files have been imported to the library and are playable.

0

Solved the importing problem:

  1. install the gstreamer plugins
  2. exit rhythmbox
  3. run the following command to remove its database records: rm ~/.local/share/rhythmbox/rhythmdb.xml
  4. open rhythmbox and try again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.