2

I installed gnome-shell and ubuntu-gnome-desktop on top of Ubuntu and now the automatic suspension doesn't seem to work (I've been using GNOME now for some time and I'm not 100% sure if it worked at some point). Also if my laptop is on battery power, the screen will dim after ~45 seconds like it should.

On Unity the automatic suspension works fine.

I wonder what service GNOME is supposed to use for power management? At least Upower.service is running according to systemd. Or is there some way to determine what programs inhibits the power manager from putting the system to sleep?

  • Have you checked the GNOME Control Panel? If you've only set it to happen with Unity's Settings, then it's not going to happen in GNOME. – TheWanderer May 5 '15 at 23:58
  • Yes I have. I forgot to mention that. – sakea May 6 '15 at 0:20
  • Stupid question. Have you rebooted? – TheWanderer May 6 '15 at 0:23
  • Yeah, this has been a problem for me for weeks. Also I just realized I'm using lightdm instead of gdm, but I don't think that should matter? – sakea May 6 '15 at 0:38
  • I'm not sure. Maybe look it up? – TheWanderer May 6 '15 at 0:39

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.