Well this happened when I upgraded to Natty. Not only seems I can't change my resolution to higher than 1024x768 but it appears at the left and using only 70% of the monitor's width.

Could not apply the stored configuration for monitors

I tried logging in but in ubuntu classic mode, and i was able to change it, but that trick did not work anymore. (May this be a compiz problem?)

Anyways, here is my /var/log/Xorg.0.log http://pastebin.com/Ew4wwLab

and lspci -nn | grep VGA:

00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03)

I tried using xrandr for adding manually a resolution of 1280x1768 but without luck. Here is the xrandr output

Screen 0: minimum 320 x 200, current 1024 x 768, maximum 4096 x 4096
LVDS1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768       60.0*+
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)
TV1 disconnected (normal left inverted right x axis y axis)
  1280x1024 (0xc6)  109.0MHz
        h: width  1280 start 1368 end 1496 total 1712 skew    0 clock   63.7KHz
        v: height 1024 start 1027 end 1034 total 1063           clock   59.9Hz


Ok, after some troubleshooting, connected the laptop to a second display and found that ubuntu is working fine. So it was a hardware problem in my Vaio laptop's screen.

  • Does this question solve your issue? – Marco Ceppi Sep 26 '11 at 11:59
  • hi @MarcoCeppi thanks for your interest. Here is what im getting http://pastebin.com/j2Ukfytv. Any idea of what that error is? – Hernantz Sep 30 '11 at 12:03
  • Have you tried using _ instead of -? Also, have you tried adding it without the -new at all and just the resolution? – Marco Ceppi Sep 30 '11 at 12:12
  • @MarcoCeppi Yes, but with the same result :( – Hernantz Sep 30 '11 at 23:55
  • Also noticed that when booting the motherboard splash screen and the BIOS are not being displayed... I think that is the problem. – Hernantz Jul 5 '12 at 1:10

Try to delete the file


I had the same problem and this worked for me.

  • Hi there, thanks for you answer. I deleted it but without luck... Any tip? – Hernantz Sep 25 '11 at 16:48
  • Doing this solved my issue in 3 chances I had. 2 with 2 TVs and one with a video beam. – Luis Alvarado Dec 9 '11 at 19:22
  • Thanks, this got rid of the error message for me! FYI though I got the error on every system start, it wasn't actually affecting anything, just an annoyance. – Michael Butler May 9 '12 at 14:01
  • Had same problem, this fixes it :) – Anthony Sottile Aug 15 '12 at 18:31

protected by RolandiXor May 16 '12 at 14:42

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.