48

Whenever I adjust the volume there's a popping sound to indicate when the volume is changing. I find it really annoying.

Is there any way to change/disable this behaviour?

12 Answers 12

62

You would have to turn the Notification sounds to off, or delete the specific sound that is played (but this would affect other event sounds and is not advised).

Screenshot: I like pie, to be honest.

  • 3
    This has the negative side effect of making Skype alerts not work as well. – Jeremy Logan Mar 30 '12 at 19:13
  • 5
    @JeremyLogan the awesome side effect though :) – Dmitry Nazarov Oct 18 '16 at 13:33
  • Can't find this option in Gnome 3.32 – jdk1.0 Jul 22 at 23:58
18

It's not really documented anywhere, but holding ALT while pressing whichever key is responsible for volume up/down/mute will change the volume setting without the pops.

These are all controlled by gnome-settings-daemon, and unfortunately while VOLUME_UP_KEY and VOLUME_DOWN_KEY are assignable, VOLUME_DOWN_QUIET_KEY and VOLUME_UP_QUIET_KEY are hardcoded to ALT+XF86AudioLowerVolume and ALT+XF86AudioRaiseVolume respectively, with no easy way to change them.

I've opened a question regarding the feasibility of making the QUIET keys assignable in a future release.

TL;DR: You can hold ALT while changing the volume to mute the pops, but you can't currently assign this action to the default keys

  • My VOLUME_UP_KEY is F4, so holding ALT while turning the volume up actually closes the current window :) – deergadan Mar 8 '18 at 14:20
  • well, if it's anything like mine, your volume up key is on the same key as F4 but has a function modifier, unless you've genuinely remapped your keys. – jymbob Mar 9 '18 at 20:42
  • I have a separate volume-key, but holding alt while pressing it makes it simply not work. Kubuntu 18.04 here – Xerus Jun 19 '18 at 21:27
  • @Xerus this question was originally asked about Unity, and is also still true for Gnome. There's a separate question with a different solution for KDE: askubuntu.com/questions/471650/… – jymbob Jun 20 '18 at 15:22
14

The following command appears to work:

gsettings set org.gnome.desktop.sound event-sounds false
  • 3
    does not work on ubuntu 12.04 – Scott Stensland Feb 3 '13 at 5:48
  • This works on 16.04 – leoredi Oct 8 '16 at 15:59
  • 3
    I couldn't make it work in 16.04. Are there things to be careful about this? Can (and should) it be reverted? – jeff Oct 26 '16 at 16:12
  • 1
    Couldn't make it work in 17.10 – morhook Feb 28 '18 at 3:46
  • 1
    Doesn't work in GNOME 3.28, even though the key exists. It's utterly unacceptable how unstable and broken gsettings/GNOME configs are. – theferrit32 Jun 5 '18 at 1:47
2

The only way I know to do that is using your mouse. You can go to the sound indicator in the upper right corner, click on it and adjust the volume in the slide bar or click on 'mute'.

  • 1
    'I would like to adjust the volume on my system without producing those "pops".' I offered a way to do this, not the best, I know, but works if she has to adjust volume silently. – leousa Jun 18 '12 at 11:13
2

Another way is to just keep the cursor on top of the volume icon and scroll to change volume.

  • 1
    This makes sounds in Gnome 3.32/Ubuntu 19.04 – jdk1.0 Jul 22 at 23:52
2

The dconf-editor settings did not help on my system, so I actually replaced the "pop" audio sound file with a silent one, and then rebooted:

# mv /usr/share/sounds/freedesktop/stereo/audio-volume-change.oga /usr/share/sounds/freedesktop/stereo/audio-volume-change.oga.backup
# cp silent.ogg /usr/share/sounds/freedesktop/stereo/audio-volume-change.oga
# reboot now

You can create a silent Ogg Vorbis file in Audacity pretty easily.

  • There is no need to put a silent audio file there, it works just as well to just rename the file. Example: sudo mv /usr/share/sounds/freedesktop/stereo/audio-volume-change.oga{,.backup} – stefansundin May 4 at 17:59
1

Go to your Sound Settings (the Volume Icon in the top right corner and click on it, and then click on the Sound Settings option at the bottom of the list.)

From there click on the Sound Effects tab. There will be a sliding bar labeled Alert Volume. Either slide it all the way to the left or just check the Mute box beside the bar. That should do it.

  • 2
    She mentioned the old thread where they give a similar solution..she doesn't want the other alerts to be affected.. – vellvisher Jun 18 '12 at 4:45
1

I've found a solution which is actually more like a workaround:

In the "Keyboard" system settings, you have to change the keybindings of volume up, down and mute and add the "Alt" key to the existing, i.e. "Alt+Volume up" and so on.

Cheers,

Dominik

I got the hint from the source file "shortcuts-list.h".

1

Go to Terminal (CTRL+ALT+T) and type in the following commands:

gsettings set org.gnome.desktop.sound event-sounds false
pulseaudio -k
0

Using Gnome-shell DE with extension volume mixer has solved problem for me. But I had to enable boost volume option in extension config

0

Still found no satisfying solution here, except killing the file with:

cd /usr/share/sounds/freedesktop/stereo/
sudo mv audio-volume-change.oga audio-volume-change.oga-DISCARDED-TOO-ANNOYING

then loging back and in again u_u

0

I had issues with the ALT solution, so for Ubuntu 19 I used (note: Yaru, not freedesktop):

mv /usr/share/sounds/Yaru/stereo/audio-volume-change.oga /usr/share/sounds/Yaru/stereo/audio-volume-change.oga.backup

Then just reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.