20

I'm trying to update and upgrade my kubuntu 15.04. After trying to install all upgrades, I got the following error message:

The following extra packages will be installed:
kde-config-telepathy-accounts
The following packages will be upgraded:
kde-config-telepathy-accounts
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/122 kB of archives.
After this operation, 1.948 kB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 626049 files and directories currently installed.)
Preparing to unpack .../kde-config-telepathy-accounts_15.04.0-0ubuntu1~ubuntu15.04~ppa1_amd64.deb ...
Unpacking kde-config-telepathy-accounts (15.04.0-0ubuntu1~ubuntu15.04~ppa1) over (0.9.0-0ubuntu1) ...
dpkg: error processing archive /var/cache/apt/archives/kde-config-telepathy-accounts_15.04.0-0ubuntu1~ubuntu15.04~ppa1_amd64.deb (--unpack):
trying to overwrite '/usr/share/accounts/services/google-im.service', which is also in package account-plugin-google 0.12+15.04.20150415.1-0ubuntu2
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
E: Sub-process /usr/bin/dpkg returned an error code (1)

How can I fix this problem?

3
  • Well, it's saying that something it's trying to install is already installed and included in another package. This prevents it from finishing the installation. Run sudo apt-get remove account-plugin-google before trying again. May 5 '15 at 1:30
  • No known answer as yet. However, a bug report has been filed on Launchpad, which in turn has been propagated upstream. You can follow their statuses here: bugs.launchpad.net/kubuntu-ppa/+bug/1451728 and here bugs.kde.org/show_bug.cgi?id=347219
    – Palantir
    May 5 '15 at 15:29
  • 1
    Same issue occurred when I try to install kubuntu and ubuntu 16.04 desktops.
    – Aruna
    May 3 '16 at 3:18
16

Deleting the conflicting packages works around the issue, until it is properly fixed.

sudo apt-get purge -f unity-scope-gdrive account-plugin-google account-plugin-facebook
1
  • Worked like a charm.
    – Ian Price
    Nov 26 '15 at 19:47
6

I saw Alisson Silveira's answer, and it was close, but apt was still broken after that. The only way I found to fix it was:

sudo apt remove unity-scope-gdrive account-plugin-google account-plugin-facebook kde-telepathy-minimal kde-telepathy

What a mess!

1
  • This worked for me too, where the other answers didn't.
    – Sam Wilson
    Apr 30 '17 at 12:54
4

The problem was solved by deleting kde-telepathy using Synaptic package manager, and now update and upgrade functions are working again.

1
  • Thank you! I had Synaptic installed and so could follow your advice!
    – DK Bose
    Jun 17 '17 at 5:22

Not the answer you're looking for? Browse other questions tagged or ask your own question.