When I try to open video files from my home server I get the error:

VLC is unable to open the MRL

I have never had this issue before. Opening internet RMTP streams works fine and firewall is disabled.

Thanks for any help

7 Answers 7


A year later... I just discovered that VLC does not use whatever connection the desktop supplies, whether it's Gnome or KDE. It creates its own using credentials defined in the settings:

Tools > Preferences

Show settings: All

Input / Codecs > Access Modules > SMB

Thanks to Joris for the information.

If it's missing install a plugin:

apt-get install vlc-plugin-samba
  • Thank you, a more meaningful error message might be something for them to consider... Nov 1, 2016 at 18:39
  • FYI link is dead
    – Elder Geek
    Feb 11, 2018 at 19:54
  • @ElderGeek: I assume you fixed it, because it seems to work now. Thanks.
    – savedario
    Feb 12, 2018 at 1:27

according to this: Question on Network Drives | Ubuntu MATE Community you need to install the 'vlc-plugin-samba'. Because it is not installed by default. What a mess! That did the trick here, but I also upgraded to vlc 3.0, because I thought this would help, but it didn't. Please let me know if it will work if you just install the plugin.

With kind regards Mangnoppa

  • I can confirm now that just installing vlc-plugin-samba with sudo apt-get install vlc-plugin-samba is working fine.
    – Kev Inski
    Nov 13, 2015 at 18:00

if it is a password protected share, you'll have to mount it with cifs:

sudo apt install cifs-utils
mkdir /mnt/share_name

then add this line to your /etc/fstab :

//server_ip/share_name        /mnt/share_name    cifs    username=user,password=pass,iocharset=utf8,sec=ntlm      0       0

and run

mount -a

play it from /mnt/share_name


Once you mounted the samba Share with nemo, you can call vlc like this:

vlc /run/user/1000/gvfs/smb-share:server=YOURSERVER,share=YOURPATH

In this approach the authentification is transparently managed within gnome, which allows to save the password in your keychain.

  • wow, this is so much easier; I've tried the SMB plugin method, but after configuring it, I couldn't find how to actually open the share /shrug
    – Marcus
    Jun 8, 2019 at 12:31

In Ubuntu 15.04, 15.10 there is a confirmed bug in the gvfs package. This causes any mounts made no to show up in /run/user//gvfs.

Where can I find the mount point for SMB shares in 13.04?

VLC uses these mounts to access and play files. If the mounts are not available, vlc uses the samba-plugin to create a connection.

A workaround is to kill the gvfsd, so a new deamon will be created when the files are accessed.

killall --user $(id -un) gvfsd

I was having trouble getting VLC in Ubuntu to play a windows share, nothing would be displayed if I navigated to the folder. What worked for me was as above activating the smb pluginl and then using add multiple files, I was able to drag and drop my entire music share into VLC, and it played perfectly.


i set in smb.conf

min protocol = SMB1

max protocol = SMB1

and works fine

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .