4

I've installed f.lux some time ago and also had it in my startup apps. But now, all of a sudden, it doesn't startup automaticall anymore. I have the command "fluxgui" in my startup applications. If I open it from console, it works without a problem. Can I somehow debug, why the program was not auto started?

1

I've experienced the same issue.

Changing the Exec field in ~/.config/autostart/fluxgui.desktop to sh -c "fluxgui >> ~/logflux.txt 2>&1" would allow you to examine the reason for the failure to start-up.

I've got the following traceback:

Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/fluxgui/fluxgui.py", line 381, in <module>
    app = Fluxgui()
  File "/usr/lib/pymodules/python2.7/fluxgui/fluxgui.py", line 17, in __init__
    self.indicator = Indicator(self)
  File "/usr/lib/pymodules/python2.7/fluxgui/fluxgui.py", line 149, in __init__
    self.setup_indicator()
  File "/usr/lib/pymodules/python2.7/fluxgui/fluxgui.py", line 162, in setup_indicator
    'gtk-icon-theme-name')
ValueError: could not find setting

Apparently, this is a known bug. However, a workaround is provided by @sricks:

This bug is still present. BUT you can fix it by modifying line 162 of /usr/lib/pymodules/python2.7/fluxgui/fluxgui.py.

Change the theme = line to look like theme = 'ubuntu-mono-dark'. If you don't have that theme installed, no problem, it just uses a default. Lines 161, 162, and 163 should look like this:

if gtk.gdk.screen_get_default():
    theme = 'ubunto-mono-dark'
    if theme == 'ubuntu-mono-dark':

This fixed the issue for me.

  • 1
    Thanks for your answer, but I found for me another solution: I just removed flux and installed redshift instead, which works perfectly. – NewtoUbuntu May 11 '15 at 9:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.