8

On ubuntu 14.04 LTS, sometimes my computer fails to launch Nautilus. This always happens when I have been working on it for a while (maybe after suspending and waking it again?), never when I just turned it on. I suspect this is related to gvfs filesystems mounted regularly and then left alone for a while. nautilus -q and similar commands give

Could not register the application: Timeout was reached

whereas sudo nautilus does launch it.

This sounds related, but I don't understand the solution.

Logging out and back in solves the problem.

I know that other people have had the same problem in the past. I do think this is a serious issue. I reinstalled ubuntu recently (for other reasons) and the problem is still there. Might be worth mentioning that I have nautilus-dropbox installed.

  • Have you tried the nemo file manager yet? (it's a fork of nautilus which has a lot more features with less of the head-aches) – Fabby May 18 '15 at 21:14
  • No, I never tried it. I may, but still, I think this is a serious issue. – Bzazz May 19 '15 at 10:47
  • 1
    Could you try? I've been using nemo using these installation instructions and have never had any problems since. If you want to find out exactly what is wrong with Nautilus, we'll have to take this up in chat as finding the exact problem might take a while. For starters: does this happen in the guest session too? – Fabby May 19 '15 at 13:15
  • Do you use Samba? If not, you may try to remove it. – Smile4ever May 25 '15 at 7:39
  • 1
    @Fabby Based on further testing on my question here Using nemo would seem to be an effective workaround/answer why not write it up? – Elder Geek Apr 30 '17 at 16:56
6

I had the same problem this morning! For no apparent reason.

I manage to restart nautilus by

killall nautilus
nautilus -q
nautilus

I'm trying to figure out what caused the mysterious failure.

4
+50

Yes, it is problably gvfs related.

The problem is this bug: gvfs should unmount remote mounts on network disconnect

Running this should allow you to use nautilus again.

gvfs-mount -s sftp & gvfs-mount -s smb & gvfs-mount -s ftp

Can take a few seconds to work

You can run it automatically. You have to write a script and save it as:

/etc/pm/sleep.d/20-gvfs

#!/bin/bash

case "$1" in
suspend)
    # executed on suspend
    gvfs-mount -s sftp & gvfs-mount -s smb & gvfs-mount -s ftp
    ;;
resume) 
    # executed on resume
*)
    ;;
esac

and

sudo chmod +x /etc/pm/sleep.d/20-gvfs
  • I suppose this is only a temporary solution to the problem? It's ok if it is. – Bzazz May 24 '15 at 9:44
  • Yes, it si temporary – Biblioclasta May 24 '15 at 23:28
  • I tried installing nscd as suggested in the ubuntuforums page I linked. Since the problem only appears from time to time, it'll be hard to check whether this helps. If not, I'll try your solution. Thanks. – Bzazz May 25 '15 at 10:33
  • I tried this on an Ubuntu 14.04 system under heavy load, sadly this didn't apply for me. (No gvfs remote mounts) although I get the same error. Any ideas? – Elder Geek Apr 30 '17 at 17:02
0

You just need to run the following commands

  1. killall nautilus
  2. Open a new terminal and run nautilus
0

killall nautilus didn't work for me.

I ran :

ps aux |grep nautilus

To list all the process containing nautilus

And I stopped them by using the following command:

kill -9 <PID>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.