1

Using 14.04 64 bit, I tried to install avidemux 2.6.8 from

ppa:rebuntu16/avidemux+unofficial

Unfortunately, the installation

sudo apt-get install avidemux2.6-qt4

failed:

dpkg: error processing archive /var/cache/apt/archives/avidemux2.6-common_2.6.8-1~ppa+trusty0_all.deb (–unpack):
trying to overwrite ‘/usr/share/man/man1/avidemux.1.gz’, which is also in package avidemux-common 1:2.5.4-0ubuntu14

Subsequent tries to install or remove something always bring up the following error messages:

You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 avidemux2.6-jobs : Depends: avidemux2.6-common but it is not going to be installed
 avidemux2.6-plugins-qt4 : Depends: avidemux2.6-qt4 (= 2.6.8-1~ppa+trusty0) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

An apt-get -f install

tries to install the dependencies, but runs into the same problem. The problem seems to come from duplicate files in the package which would overwrite each other during installation.

What to do? How can I repair the package system?

1

Let aptitude solve the problem for you.

sudo apt-get install aptitude

Start aptitude

sudo aptitude

In the bottom line problem solutions are offered.

enter image description here

Use E for Examine and . and/or , to move between proposed solutions

Apply with !

And Go with G

  • That does not work. The remove attempt brings up the same error message as described above. – hako May 4 '15 at 9:47
  • New solution with aptitude – A.B. May 4 '15 at 10:05
  • After disabling the ppa, I could successfully run "sudo apt-get -f install". Then, I was able to remove several packages of avidemux, and install aptitude. Using aptitude I cleaned up. Now trying to install from the ppa, again. – hako May 4 '15 at 10:26
  • I had to disable the ppa to overcome the problem. "apt-get -f install" tries to solve the dependencies, and that ran into the same problem, again. Now, I have re-activated the ppa, and successfully installed avidemux 2.6.8. Thank you for the tips. – hako May 4 '15 at 10:39
  • @hako Were you satisfied with my answer? Then give me an upvote (∧). If I could solve your problem, then it would be nice if you'd mark my answer (✓). askubuntu.com/help/someone-answers ;) – A.B. May 4 '15 at 10:39
0

The above solution did not work for me (it gave the same error). What worked was hako's solution - remove the PPA repository by opening Ubuntu Software Center -> Edit menu -> Software Sources -> Other Software and then uncheck both the PPA records (including the source code link) for Avidemux. After this run the command

sudo apt-get -f install

to resolve this error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.