I have installed Ubuntu 14.04(Dual Boot with Win 8.1) lts with about 12-13gb disk space.
I installed Steam and tried to install DOTA 2 which requires about 10gb of space ,but I have only 6 gb left.
I tried installing it on a different partition(windows) however it refuses to select a directory in any of the windows partition stating the above error:
Steam Library must be on a filesystem mounted with execute permissions 1


i found a very easy answer for this problem, just type this in the terminal udisks --mount /dev/sda2 --mount-options umask=022 (mounts with exec) steam will accept the windows partition and start downloading/installing your game.


Add an entry in the fstab file at: /etc/fstab for your device. With "exec" option, for example:

UUID=6C046CDF046CADB0 /media/SAMSUNG ntfs rw,user,auto,exec    0    0

There is a workaround.

  • In windows create the Steam Library on the Windows drive
  • In linux create a new Steam Library on you linux partition.
  • Close Steam and remove the files inside the Steam Library folder.
  • Link your newly created Steam Library on linux to your windows Steam Library with:
    ln -s /path/to/windows/Steam_Library /path/to/linux/Steam_Library
  • I have done this , and what it does is create some kind of shortcut? It still shows the same error.And what should i delete Steamapps or steamlibrary content, as there is no steamlibrary in the ubuntu one. – Spandan Pujari May 4 '15 at 9:56
  • This will create a link on your linux filesystem pointing to your windows partition. Steam will work because the link file is on your linux partition, but the files are actually stored on the windows paritition. Linking Steamapps should be enough. – Pabi May 4 '15 at 10:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.