I was printing fine to an Lexmark CX310dn printer with my Ubuntu 12.04 box until a few days ago. Now when ever I print something I notice the text

foomatic-rip failed

next to the printer name at the print dialogue.

In the CUPS control center (http://localhost:631/) I see that the driver for my printer is

Driver: Lexmark 2050 Foomatic/c2050


I ran

tail /var/log/cups/error_log

after a failed print and noticed this line a few lines before the foomatic-rip failed error

bash: c2050: command not found

So I tried these commands:

$ c2050
The program 'c2050' is currently not installed.  You can install it by typing:
sudo apt-get install printer-driver-c2050

$ sudo apt-get install printer-driver-c2050

After this the printer started printing but was printing garbage. So I first I rebooted the printer and then I removed and re-added the printer. I did it the hard way but you can try the easy way through System Settings first. Anyway, in my case first I added the driver suggested on http://www.openprinting.org/printer/Lexmark/Lexmark-CX310dn. I downloaded the deb file and installed it with

sudo dpkg --install openprinting-ppds-postscript-lexmark_20140829-1lsb3.2_all.deb

and then I visited the CUPs interface and added the printer.

Case solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.