I experienced this problem with konversation, but while searching for a solution, I saw that many people were having this problem with many different KDE programs, so I thought I'd bring it up here

I'm running lubuntu (a GTK based distribution), but I run several KDE programs, including konversation. When I was running 14.10, konversation worked without issue, but when I upgraded to to 15.04, I was no longer able to right click and save links. When I tried, I received the following message:

could not start process cannot talk to klauncher the name org.kde.klauncher5 was not provided by any .service files

How can I solve this problem and be able to right-click and save links again?


SUMMARY: apt-get install kinit kio kio-extras kded5


After much searching and experimenting, I was able to find a solution for this problem.

klauncher is a daemon for service activation in KDE and is controlled by kdeinit supplied by the kinit package. This package was not installed, so I installed it:

apt-get install kinit

Once I installed kinit, the error message went away, but was replaced by another error message:

could not start process unable to create io-slave klauncher said: unknown protocol 'file'

After some searching I realized I had to install the KDE Input/Output framework:

apt-get install kio

This solved the problem, but to be sure I also installed kio-extras:

apt-get install kio-extras

I am now able to right-click and save links without issue. I did still get the following error message when running konversation from the command line:

Can't communicate with kded_kcookiejar!

Using @Graham's solution, I was able to resolve this issue:

apt-get install kded5

EDITED TO ADD: There still seems to be one outstanding issue. Even though I can save the links, it doesn't remember the last folder I used. Before I upgraded to 15.04, the last folder I saved something to was remembered the next time I tried to save something.

Now, this is not the case. The "Save As" dialog does not remember the last used directory. Instead, it defaults to the directory I run konversation from.

I'm still looking for a solution for this.


If it still doesn't work do:

sudo apt-get install kded5

As well as the other stuff.

  • This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. – Fabby Oct 27 '15 at 18:43
  • 1
    I'm less about being pedantic about the functions of this site and more about providing answers for people with problems. If one has a problem with that then they can always change it themselves. – Graham Oct 28 '15 at 10:03
  • then you should have edited the existing answer... (You can, you know) ;-) – Fabby Oct 28 '15 at 20:49
  • @Graham: Thanks for that, that solved my problem with remembering the last used directory, and I'm no longer getting kded_kcookiejar errors. I'm going to add it to my answer. – Menachem Oct 29 '15 at 7:53
  • @Graham: Unfortunately, while my kcookiejar errors went away, it still doesn't remember the last used directory. It seemed like it did for a day, but it no longer does. – Menachem Nov 17 '15 at 1:32

The issue appears to be related to permissions. I installed K3B and all related dependencies from the software center. when I attempted to open the application using the menu icon the application would open and reported the following error: '' Could not start process Cannot talk to klauncher: The name org.kde.klauncher was not provided by any .service files.'' I closed the application and opened a terminal window. I typed '' sudo K3b'' entered mu password and the application ran without issue. (do not close teh terminal window while using K3B). I have been running K3b as su and have not had any errors or issues burning CD or DVDs. CB

  • Forgot to add I'm running Linux MInt 18 Cinnamon 64-bit, Cinnamon version 3.0.7 on Kernel 4.4.0-45-generic – Clyde B Oct 22 '16 at 15:33

protected by Community Feb 17 '17 at 13:24

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.