1

I lost power briefly today, when my headless ubuntu server rebooted I could no longer SSH into it. I assumed the drive had failed or something. I took out the drive, put it into a USB SATA enclosure and connected to my windows PC. I tried booting from it and it does actually still boot, however, when it was booting there was a few error messages about not being able to resolve the network and proceeding with no network connection.

So it seems all my files are intact, however, I have no connection. When I run ifconfig -a there is no inet address listed under eth1.

Any ideas on what my issue could be?

Thanks

Edit: Ok so my /etc/network/interfaces file only had details for lo and eth0. I added this to the file:

auto lo eth0
iface lo inet loopback

network is now working. However when I put the drive back into my home server box I still can't access it over SSH. It still doesn't seem to boot. I'm not sure why it would boot from an external enclosure and not the server box. Maybe something else inside the server box is fried?

  • Only having auto lo; iface lo inet loopback in /etc/network/interfaces is normal. Are you set up static or dynamic IP? If dynamic, you probably just need to run dhclient. – cremefraiche May 4 '15 at 2:05
0

You shouldn't be grouping each interface together like you did. Start by defining each section for networking separately like below, with different auto entries corresponding with each interface. Also remember you need to provide a different iface line for each device as well.

Like this:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.