I am running ubuntu 11.04 at my asus laptop.

Laptop specs:

CPU: i5-2410M @ 2,3GHz
GPU: nvidia gforce GT 520M / (also the cpu has a bult-in graphics processor)

I am getting this error when I am trying to access the X server settings:


Also, there is no xconfig file in the etc/x11 directory. Only the "xorg.cong.backup".
I've tried sudo startx and I got this:

Fatal server error:
Server is already active for display 0
    If this server is no longer running, remove /tmp/.X0-lock
    and start again.

Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 

 ddxSigGiveUp: Closing log
XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
      after 7 requests (7 known processed) with 0 events remaining.

What is wrong?

Thank you for your time!

  • I couldn't help but notice that it looks like you are using Unity 2D. I'm thinking you not only can't access your X settings, but you're not able to run 3D as well. Sep 17 '11 at 15:49
  • what graphics driver are you using? there is a beta and a "safe" version! (properity driver)
    – Alvar
    Sep 17 '11 at 16:25
  • With this command "dpkg -l | grep nvidia" I got this: ii nvidia-common 0.2.30 Find obsolete NVIDIA drivers ii nvidia-current 270.41.06-0ubuntu1 NVIDIA binary Xorg driver, kernel module and VDPAU library ii nvidia-settings 270.29-0ubuntu1 Tool of configuring the NVIDIA graphics driver
    – Chris
    Sep 17 '11 at 20:12

The GT 520M is a nVidia Optimus laptop which is unsupported in Ubuntu. There are ways to get program to run on the nvidia card though which is described in Is a NVIDIA GeForce with Optimus Technology supported by Ubuntu?

After installing Bumblebee, you are able to run nvidia-settings using:

optirun nvidia-settings -c :8

Do not just run nvidia-xconfig, it'll create the /etc/X11/xorg.conf configuration file which breaks compositing and such because the driver does not support the nvidia card out-of-the-box. If you've already ran that command, remove the file:

sudo rm /etc/X11/xorg.conf
  • 2
    Thank you for your reply! I have done all the four steps you have mentioned in the other question. You have written "If you'd like to run a program on the nvidia card now, use the optirun program". 1) So now every program is running on the built-in graphics processor of the CPU? 2) Is this built-in gpu handling the windows effects as well? 3) Which programmes should I run on the nvidia card? 4) To get this right, the whole problem is due to the optimus technology on my nvidia gt 520m? 5) I tried running this: nvidia-settings -c :8 and got this: ERROR: Cannot open display ':8'.
    – Chris
    Sep 17 '11 at 13:28
  • 2
    1) A program is rendered on the nvidia card but the result is displayed using the intel card 2) No, the desktop runs on the intel card. You can try to run the whole session using optirun by editing the session file in /usr/share/xsessions, but this may not be that stable since not all GL features are (correctly) implemented. 3) Programs which heavily rely on graphics like internet browsers (Firefox, Chromium) and media players (VLC). Keep in mind that the nvidia card uses more power, so only use it if really needed 4) Correct. 5) The Bumblebee X server was not started. Run it with optirun.
    – Lekensteyn
    Sep 17 '11 at 13:50
  • 1)So now, firefox runs on the intel card, right? 2)You mean that I have to run every program I want using this command "optirun program &"? Which means that if I want to open a movie I will firstly have to open vlc via that command and then open the video file? :S Isn't there any way to choose which programmes will run on the nvidia card? 3)About the 5th question and the answer you provided.How should I start the bumblebee x server?Which command? This: optirun bumblebee -d ? Sorry I'm not an experienced user..
    – Chris
    Sep 17 '11 at 14:34
  • 1) Correct 2) Indeed. You can edit the desktop files to make it run in optirun, which is what bumblebee-ui does. Unfortunately, it is not compatible yet with recent Bumblebee releases 3) It is started on boot time and after installation of Bumblebee. You'll be given instructions on using optirun when it's not started.
    – Lekensteyn
    Sep 17 '11 at 15:42
  • 1
    @Lekensteyn If I run nvidia-settings via optirun as indicated in this answer they are useless because they refer to virtual screen is that correct? If yes, how can one take profits from those advanced screen settings which Nvidia X server settings normally provides?
    – Patryk
    Jan 12 '14 at 20:48

Have you tried running in the terminal:

sudo nvidia-xconfig

and then rebooting? That should take care of it all for you.

  • Tried that and got this: WARNING: Unable to locate/open X configuration file. New X configuration file written to '/etc/X11/xorg.conf'. After that I rebooted and got this screen: tinypic.com/r/mrdvt/7 I've managed to boot at ubuntu into failsafe graphics mode. So this problem ( askubuntu.com/questions/61559/…) is not solved.
    – Chris
    Sep 17 '11 at 12:36
  • I failed to notice that you are using an Optimus card and merely noticed that you never mentioned running the command I recommended you. Lekensteyn's answer is better suited than my own. Apologies.
    – user6658
    Sep 17 '11 at 15:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.