0

This started maybe half an hour ago(as of 5:35 pm U.S. Central Time) after I downloaded a security update; I decided to restart the computer soon, and after quickly saving work on some programs, I let the computer do its thing.

However, I had had some really strange issues with Firefox earlier in the day (including losing the ability to restore my previous session, and locking up after only opening a single tab), so, before resuming my work on Ubuntu 14.10 I decided to try to go into Recovery Mode, to see if I could find out what was wrong; fixing broken packages was apparently not an option, so I thought I'd try going into the failsafe graphic mode for a while, thinking that might help.

Unfortunately, I wasn't able to progress beyond the initial warning screen(I tried everything I could think of, using a USB mouse, key combos, etc. nothing worked), so I had to do a hard reboot.

And that, I believe, is where it got to that point of being unable to boot; I even tried loading a previous kernel of Ubuntu 14 which also didn't work-both times, it seemed to load up fine, but then hung up on a black screen, with no indication of a grub error or anything like that.

The good news is, Windows 8 still seems to work okay, so I doubt it's a hard drive related issue, but what could have borked Ubuntu so badly that it suddenly stops booting with no warning? Could the Firefox issues have been a symptom, perhaps?

  • Is there a message on the screen or is it just black? Does GRUB load up? – user246462 May 3 '15 at 23:13
  • What error messages and warnings did you get/ – Wilf May 3 '15 at 23:32
  • No, it's just black, although GRUB loads just fine. – AlternateSteve90 May 4 '15 at 0:11
  • None that I can recall, Wilf, which is why I'm a little confused at the moment. Having thought about this a little more, I do also recall having a few more minor issues with Firefox(automatically logging out within a short period from sites where I can normally stay logged in for weeks at a time), going back a few days, and I did come over to find a black screen earlier this afternoon after it went to standby the night before, though I was able to get out of that, and Firefox didn't start having major issues until about 5 pm my time today. So, I'm at a loss as to what's going on. – AlternateSteve90 May 4 '15 at 0:13
  • If you have more than one kernal, try a different one. If not try to get some error messages printed while booting by editing the kernal boot parameters (In grub select the kernal you want to use, press e and remove quiet and splash from the parameters list and then boot. Post back the errors. – Ron May 4 '15 at 5:11
1

Okay, well, as it turned out, following a hunch, all I needed to do was to start a file system check with the fsck utility; turns out, the system hadn't been unmounted properly for some reason, and was still in read-only mode. So, it saved me the pain of having to re-install the system (which I came pretty close to trying!) when that actually wasn't needed.

(Still, though, at least now, if Unicorn ever does get really, truly, badly effed up before I try Vivid, I have a backup CD ready to go.)

I do still have at least one other issue to work out, but Ubuntu is finally working again, and I'm grateful for that. So, thanks to everybody who offered their help-it was, and is, appreciated. =)

  • Given this solved your problem you may want to mark this as an accepted answer to let others know your question is answered. There's nothing wrong with marking your own answer as accepted. – thomasrutter May 5 '15 at 0:39
  • Raring? dude, are you still using 13.10 or was that a misprint? – mchid May 5 '15 at 5:47
  • Yeah, that was, actually. I apologize for the error, and have since corrected it. =) – AlternateSteve90 May 5 '15 at 7:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.