I keep getting the Transmission "Permission denied" error when adding a magnet/torrent. Initially, I looked up this pretty common problem, yet the solutions did not solve my issue.

I ran ps -ef | grep transmission and got this:

debian-+ 3128 1 0 14:22 ? 00:00:03 /usr/bin/transmission-daemon -f --log-error

User 8906 32499 0 15:24 pts/3 00:00:00 grep --color=auto transmission

For some reason, the process name "/usr/bin/transmission-daemon" is different from many others ( simply transmission-daemon).

Is this due to init.d depracation?

How do I get the process to run as my user?


Search for 'qBittorrent' in the Ubuntu Software Center, install.

Then run this in the terminal: sudo qbittorrent

Copy the address of the torrent link, paste into qBittorent via 'paste from clipboard' option in 'New' tab.

Find some cold beer and a place to chill....


  • OP is asking for help with transmission. Not bittorrent in general. Also, I'll bet that qbittorrent shouldn't be run as root. And if it should be, it's probably not a good replacement. – user3113723 May 7 '15 at 20:23
  • Works for me... – RCline7 May 25 '15 at 15:53

Not 100% what you're asking, but: /usr/bin/transmission-daemon is due to the program being run using the full path, which is legal for any program. it's not an issue at all.

As far as running as your user: transmission-daemon by default runs as a specially-created user called 'transmission-daemon.' this is a common security thing (see below), and isn't necessarily the cause of your problem. I run it as the special user on one of my machines, and it doesn't prevent me from adding torrents.

You should set the config option 'message-level' to 3 and see if the log file provides useful info. My guess is you're trying to save something (the torrent, the target file, resume data, etc) to a location transmission-demon can't write to, because you've changed the default locations for saving these files. If you want them saved to a particular place, you can set up transmission to move the files to a new location when the dl completes, with permissions set up such that transmission-daemon can write there.

Possibly (i forget my permissions-fu) you could add the transmission-daemon user to the $YOUR_USER_NAME group. this will probably allow it to write where you want it to write.

in re the security thing: the idea is that since one use of transmission-daemon is to listen to requests from the internet so you can send download jobs to your computer at home or something, it's an attack target. so in the event that somebody hacks it, you want to be sure they don't thereby control your whole machine. so you make a user called transmission-daemon which can only do a few things like run transmission-daemon. this makes it harder to turn hacking transmission-daemon into full-fledged pwnage.

of course, adding transmission-daemon to your user group will probably make it a lot easier, but whaddaya gonna do?

  • Funny you should say that...I've already added transmission-daemon to my usergroup, and even made sure that transmission can write to the specified path. That's why I'm going insane with this haha – therza May 8 '15 at 1:39
  • can you post the ls -l output for the path, and the exact error from transmission? – user3113723 May 8 '15 at 2:14
  • I really screwed up my system trying to fix this (gotta love desperation) and now I can't use sudo due to /usr/bin/sudo must be owned by uid 0 and have the setuid bit set So I'm just going to reinstall linux, and revert back to 14.04. Thanks anyway – therza May 9 '15 at 4:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.