5

In Ubuntu 14.10 and prior, I used to go to gnome-control-center, click Keyboard, and there was some "advanced" section with a list of checkboxes where I could set which key to use as the Compose key. I used the Menu key, but that setting got destroyed with the upgrade, and the Menu key now opens a right-click menu.

However, in Ubuntu 15.04, gnome-control-center is gone, and when I manually install it using sudo apt-get install gnome-control-center, it only contains three options: Language Support, Printers, and Software & Updates. No Keyboard section in sight.

As you may have guessed, I'm not using the Unity desktop (but Xmonad). What is the new recommended way to set which key is mapped to Compose?

I'm not averse to editing configuration files, but Ubuntu has a way of breaking unsupported customizations in every new version, so I'd rather do this the "official" way.

8

Try unity-control-center -> Keyboard -> Shortcuts -> Typing -> Compose Key.

  • Great, thanks! This would have answered the question... except I seem to have asked the wrong question, because it's already set to "Menu". – Thomas May 4 '15 at 15:46
  • Asked askubuntu.com/questions/618202/…. – Thomas May 4 '15 at 16:02
5

There is no official way. Install and open the dconf editor:

sudo apt-get install dconf-editor
dconf-editor

Go to org.gnome.desktop.input-sources and change the entry for xkb-options, eg:

['terminate:ctrl_alt_bksp','compose:menu']

Replace the value for menu in 'compose:menu' if you need another one. You can an option from the list below. The changes are effective immediately.

More options are listed in the xkeyboard-config manpage:

   +------------------------------------------------------+
   |Option                Description                     |
   +------------------------------------------------------+
   |compose:ralt          Right Alt                       |
   |compose:lwin          Left Win                        |
   |compose:lwin-altgr    3rd level of Left Win           |
   |compose:rwin          Right Win                       |
   |compose:rwin-altgr    3rd level of Right Win          |
   |compose:menu          Menu                            |
   |compose:menu-altgr    3rd level of Menu               |
   |compose:lctrl         Left Ctrl                       |
   |compose:lctrl-altgr   3rd level of Left Ctrl          |
   |compose:rctrl         Right Ctrl                      |
   |compose:rctrl-altgr   3rd level of Right Ctrl         |
   |compose:caps          Caps Lock                       |
   |compose:caps-altgr    3rd level of Caps Lock          |
   |compose:102           <Less/Greater>                  |
   |compose:102-altgr     3rd level of <Less/Greater>     |
   |compose:paus          Pause                           |
   |compose:prsc          PrtSc                           |
   |compose:sclk          Scroll Lock                     |
   |                                                      |
   +------------------------------------------------------+
  • Very helpful, thanks! However... there's already 'compose:menu' in the list, so apparently it's not working (I'm still getting the right-click menu). Any ideas? – Thomas May 3 '15 at 17:15
  • @Thomas Which right-click menu? – A.B. May 3 '15 at 17:18
  • Whatever menu you'd get when right-clicking the mouse on the thing that currently has the keyboard focus. Just like Windows does it, basically. – Thomas May 3 '15 at 19:34
  • @Thomas I thought you wanted to change the entry for "xkb-options"? Single click on ['compose:menu']. – A.B. May 3 '15 at 19:38
0

If unity-control-center -> Keyboard -> Shortcuts -> Typing -> Compose Key (as suggested earlier by @mhansen) is Disabled and you cannot change it, installing ubuntu-tweak-tool will make it changeable. See also this thread.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.