2

I upgraded my system from Ubuntu 14.10 to Ubuntu 15.04 flawlessly. But for some reason, it always jumps straight into standby (suspend) mode directly after login. I have to use the notebook's power button to wake it up, then it's finally logged in and I can use the system. This is annoying. I'm using a Thinkpad T61.

Here's the log immediatly befor it jumps into suspend:

moon:/var/log$ cat syslog|grep suspend

May 16 19:27:20 moon kernel: [ 838.913403] Suspending console(s) (use to_console_suspend to debug)

May 16 19:27:20 moon kernel: [ 839.391898] PM: suspend of devices complete after 478.104 msecs

May 16 19:27:20 moon kernel: [ 839.392466] PM: late suspend of devices complete after 0.564 msecs

May 16 19:27:20 moon kernel: [ 839.408169] PM: noirq suspend of devices complete after 15.699 msecs

May 16 19:27:20 moon systemd[1]: Unit suspend.target is bound to inactive unit systemd-suspend.service. Stopping, too.

3
  • It happens every time when I boot up freshly and login.
    – de-facto
    May 7, 2015 at 10:58
  • It also happens when I use the guest account to login. It once happend too while logging out of the guest session.
    – de-facto
    May 9, 2015 at 8:17
  • I restarted the system today and it didn't suspend after login for the first time. But the problem should be related to systemd, since it is new in Ubuntu 15.04. Anyway I can't find any information for the cause in systemd's configuration files. I don't know which logs I could check furthermore. But I found out, there is a new aspect to the problem: It also suspends automatically using STRG+ALT+F2 to change to terminal. I have to use the power button to resume it, after logged in in the terminal it doesn't suspend. Switching back to X by STRG+ALT+F7 causes the system again to suspend.
    – de-facto
    May 16, 2015 at 17:11

1 Answer 1

4

Somebody found a solution:

Problem completely solved by setting "HandleLidSwitch=ignore" in /etc/systemd/logind.conf. From here: Ubuntu 15.04 suspends ~30 seconds after resume

1
  • This helped me too (on 18.04). I had already set HandleLidSwitchDocked=ignore, but I had to set HandleLidSwitch=ignore as well to solve this problem, even though my laptop is always docked. Seems like it briefly forgets it's docked after login!
    – Sam
    Oct 9, 2019 at 8:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.