3

I have repeatedly tried to install on Ubuntu 15.04 64 bit drivers for controller xbox360 and always got the same error after performing the following commands:

sudo apt-add-repository -y ppa:rael-gc/ubuntu-xboxdrv
sudo apt-get update
sudo apt-get install ubuntu-xboxdrv
...

Configuring the ubuntu-xboxdrv package (20150319-1) ...
/usr/bin/update-desktop-database
Failed to start xboxdrv.service: Unit xboxdrv.service failed to load: No such file or directory.
dpkg: error processing ubuntu-xboxdrv (--configure) package:
  subprocess installed post-installation script returned error code 6
Configuring the evtest package (1: 1.32-1) ...
Configuring the joystick package (1: 1.4.7-2) ...
Parsing libc-bin (2.21-0ubuntu4) triggers ...
Processing ureadahead (0.100.0-19) triggers ...
Processing dbus packet triggers (1.8.12-1ubuntu5) ...
There were errors while processing:
  ubuntu-xboxdrv
E: Sub-process /usr/bin/dpkg returned an error code (1)
1
  • This is a Grandfather question from 2005 and has a score of 3. Leave open. May 12, 2022 at 14:51

1 Answer 1

0

Try the following (after the above installation attempt - when the install fails). It solved the same issue I had while installing ubuntu-xboxdrv:

  1. Go to https://github.com/raelgc/ubuntu_xboxdrv/tree/master/src/lib/systemd/system, right click on xboxdrv.service and select "save linked content as" or "save target as" and save it as "xboxdrv.service" in an easily accessible path.

  2. Open a terminal and navigate to the above path where xboxdrv.service is and run the following command :

    sudo systemctl enable xboxdrv.service

  3. Then run sudo apt-get install ubuntu-xboxdrv again.

This should solve the problem.

Credit: https://www.digitalocean.com/community/tutorials/how-to-use-systemctl-to-manage-systemd-services-and-units

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.