11

Ubuntu 15.04 Dell XPS-13

I can connect my audio devices via Bluetooth, but I can not use them as they don't show up in sounds settings as an output option (or input option).

How do I fix this?

4 Answers 4

5

I tried to load the module first but I got a Failure: Module initialization failed so you have to unload the module first:

pactl unload-module module-bluetooth-discover

and then load it again:

pactl load-module module-bluetooth-discover

After that I was able to see the audio device in audio settings.

1
  • Welcome to AskUbuntu :) I think you should add some detail to your answer, since it won't make much sense without the other answer. If your answer is the correct one it will be boosted to the top, and will thus be out of context. Dec 9, 2015 at 23:21
3

I had the same issue here with Ubuntu Gnome 15.10 and 16.04. What helped me was adding read permissions for the gdm user on the pulseaudio bin.

sudo setfacl -m u:gdm:r /usr/bin/pulseaudio

after that restart pulseaudio (or restart your system)

pulseaudio -k

your bluetooth device should now be listed in the audio device list.

5
  • 1
    I get: setfacl: Option -m: Invalid argument near character 3
    – weelux
    Oct 11, 2016 at 10:55
  • That did the trick for me, too! Thank you so much! I was looking for a fix for this issue all over!
    – mjb
    Oct 13, 2016 at 9:18
  • gdm needs to be your user ID (username seems to work too) - I'll edit the answer Jul 21, 2017 at 9:14
  • This command made even the internal audio device disappear! How to fix? Jul 21, 2017 at 10:00
  • Use sudo setfacl -m u:1000:r-x /usr/bin/pulseaudio where 1000 is your user id. Type id in a terminal to view your id. Keep in mind to use r and x else all output devices are gone! Jul 21, 2017 at 10:33
2

Blueman has a bug that will unload module-bluetooth-discover if it is loaded during boot so that you will likely need to unpair the audio device and then

pactl load-module module-bluetooth-discover

Then pair your device and see if it appears in sound settings

6
  • 4
    (when I run) ~ $ sudo pactl load-module module-bluetooth-discover (I get) Failure: Module initialization failed May 3, 2015 at 18:32
  • When I try to install blueman bluetooth manger I get paste.ubuntu.com/10980288 May 3, 2015 at 18:44
  • I am not sure what is going on
    – Jeremy31
    May 3, 2015 at 20:29
  • Similar problems here $ sudo pactl load-module module-bluetooth-discover Home directory not accessible: Permission denied Connection failure: Connection refused pa_context_connect() failed: Connection refused $ sudo -i pactl load-module module-bluetooth-discover Connection failure: Connection refused pa_context_connect() failed: Connection refused
    – select
    Nov 25, 2015 at 23:07
  • 2
    @select Pulseaudio runs as your user, so you shouldn't use sudo with it - the error messages you cite are totally different, and due to using sudo. Feb 25, 2016 at 19:31
0

After successful connecting of the bluetooth headset, try
sudo -i pactl load-module module-bluetooth-discover

If that then allows you to select the headset as an output device, you can make the following changes:

nano /etc/pulse/default.pa

Comment out the following lines:

#.ifexists module-bluetooth-discover.so
#load-module module-bluetooth-discover
#.endif

Then in:

nano /usr/bin/start-pulseaudio-x11

Find the following lines and add after them:

if [ x”$SESSION_MANAGER” != x ] ; then
/usr/bin/pactl load-module module-x11-xsmp “display=$DISPLAY session_manager=$SESSION_MANAGER” > /dev/null
fi

# Add the following lines:
/usr/bin/pactl load-module module-bluetooth-discover
# /usr/bin/pactl load-module module-switch-on-connect #<-- Uncomment to automatically select headset on connection
1
  • what if I get Connection failure: Connection refused after first command?
    – Bassie
    Dec 6, 2021 at 10:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .