2

I have an ODroid U2 running Ubuntu 14.04 LTS and Linux version 3.8.13.30.

I am trying to get my USB WiFi dongle working through this tutorial.

However, at the sudo dkms install 8192cu/1.10 stage, I am getting the following error:

Error! Your kernel headers for kernel 3.8.13.30 cannot be found.
Please install the linux-headers-3.8.13.30 package, or use the --kernelsource dir option to tell DKMS where it's located`  

So, I did dpkg -l | grep linux-headers to find that linux-headers-3.13.0-51 was installed at /usr/src.

I passed this data to DKMS through the --kernelsourcedir option but got the same error:

I also did apt-get install linux-headers-$(uname-r) but got an Unable to locate package error.

What am I doing wrong/How can I fix this?

2
  • Wonder what you did to use a kernel from a previous release, as ubuntu 14.04 comes with Linux 3.13. – xangua May 2 '15 at 22:09
  • @xangua I didn't check exactly. I recently did a fresh install of Ubuntu and got an option to update kernel. When I did, this is what I have currently. – Kanishka Ganguly May 2 '15 at 22:20
2

I found the correct headers here.

How to add this repository:

sudo -i
cd /etc/apt/sources.list.d
wget https://oph.mdrjr.net/meveric/sources.lists/meveric-all-main.list
wget -O- http://oph.mdrjr.net/meveric/meveric.asc | apt-key add -
exit
sudo apt-get update

You can then use APT to install the headers you need.

0
0

If you take a look at this page: http://kernel.ubuntu.com/~kernel-ppa/mainline/, you'll see that particular version is not available (anymore). It is probably better to install a newer kernel from the page mentioned and then try to compile the dkms module again.

7
  • I just updated my kernel via the ODroid Utility. – Kanishka Ganguly May 2 '15 at 21:52
  • No matter how you update if you don't install matching headers you can't compile kernel modules, like the error message tells you also. – wie5Ooma May 2 '15 at 21:56
  • So, how would I update the kernel to match the already installed linux-headers? – Kanishka Ganguly May 2 '15 at 21:57
  • You can't. You'll have to match the headers with the kernel installed not the other way around. Matching the kernel with the headers means effectively downgrading your kernel which is not advisable or even impossible. Install a newer kernel with the marching headers using dpkg. – wie5Ooma May 2 '15 at 22:00
  • So that is what I tried. However, as you pointed out, the headers for that particular version isn't available anymore. – Kanishka Ganguly May 2 '15 at 22:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.