1

Opening firefox through the desktop icon will show the loading cursor, but a few seconds later it will stop loading and never open a firefox window. It is possible to load firefox from the terminal, but only in safe mode. I get the following error when attempting to load in terminal:

(process:26701): GLib-CRITICAL **:g_slice_set_config: assertion 'sys_page_size== 0' failed

I have found several pages suggesting the following will fix this problem:

chown -hR YOUR_USER .gnome2/

chown -hR YOUR_USER .gnome2_private/

however, this did not help, I got the following error:

chown: cannot access '.gnome2/': No such file or directory

chown: cannot access '.gnome2/private': No such file or directory

Any suggestions? I have removed firefox and re-installed in terminal, but the same error still occurs.

7
  • In many cases, if an application still doesn't work as expected after a reinstall, it is the local files that are corrupted. Please try removing (-renaming temporarily) ~/.mozilla, log out/in and try again. – Jacob Vlijm May 2 '15 at 20:01
  • still new to Ubuntu, what would the command line be in terminal? – Rob_674 May 2 '15 at 20:02
  • 1
    I had missed the logging out/in step, thank you. It is now working properly. – Rob_674 May 2 '15 at 20:14
  • 1
    Cool! Would you mind if I posted it as an answer? – Jacob Vlijm May 2 '15 at 20:15
  • 1
    If the answer solves your issue, like you mentioned in a comment, please mark it as accepted (below the up/down arrows on the left). Otherwise it will re-appear as unanswered... – Jacob Vlijm May 3 '15 at 18:23
2

Most likely:

In far most cases, if an application still does not work after a (complete) reinstall, its local settings files or profile(s) are corrupted for some reason.

In this case, the firefox local files are in ~/.mozilla

What to do:

You should either remove the directory ~/.mozilla or, if it contains valuable settings, first try to rename it. Then (best before running Firefox again), log out and back in.

.desktop files

Another option, although not very likely in this case, is an outdated or otherwise incorrect local .desktop file in ~/usr/share/applications. This can especially be the case if an application is updated to a newer version.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.