2

I've recently upgraded to 15.04 and immediately noticed significantly faster battery depletion and warmer case. My MacBook Air 6,2 would easily hold 10-12 hours on battery power with Ubuntu 14.10 and now it only holds 3 hours(!) I've tried using tlp, removing powerclamp (I noticed 4 x kidle_inject) and playing with other parameters. The current workaround is booting with the older and better 3.16.0-36.

Does anyone else experiencing the same? Anyone knows how to solve this? I can provide any information and will try anything to solve this.

EDIT: Per a request in the comments, this is the same with both kernels:

$ cat /proc/cpuinfo | grep "model name"
model name  : Intel(R) Core(TM) i7-4650U CPU @ 1.70GHz
model name  : Intel(R) Core(TM) i7-4650U CPU @ 1.70GHz
model name  : Intel(R) Core(TM) i7-4650U CPU @ 1.70GHz
model name  : Intel(R) Core(TM) i7-4650U CPU @ 1.70GHz
$ cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_driver
intel_pstate
$ cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
powersave

EDIT 2: sudo turbostat -S sleep 300

With 3.16.0-36:
Avg_MHz   %Busy Bzy_MHz TSC_MHz     SMI  CPU%c1  CPU%c3  CPU%c6  CPU%c7 CoreTmp  PkgTmp Pkg%pc2 Pkg%pc3 Pkg%pc6 Pkg%pc7 Pkg%pc8 Pkg%pc9 Pk%pc10 PkgWatt CorWatt GFXWatt
      82    4.85    1689    2299       0   10.08    1.91    0.93   82.23      52      52   20.91    2.16    6.80   45.68    0.00    0.00    0.00    2.07    0.43    0.07

With 3.19.0-15:
 Avg_MHz   %Busy Bzy_MHz TSC_MHz     SMI  CPU%c1  CPU%c3  CPU%c6  CPU%c7 CoreTmp  PkgTmp Pkg%pc2 Pkg%pc3 Pkg%pc6 Pkg%pc7 Pkg%pc8 Pkg%pc9 Pk%pc10 PkgWatt CorWatt GFXWatt
     111    4.82    2295    2300       0   10.17    2.63    1.03   81.35      58      58   18.73   49.94    0.00    0.00    0.00    0.00    0.00    4.54    0.86    0.66

EDIT 3: turbostat when completely idle and X turned off

With 3.16.0-36:
Avg_MHz   %Busy Bzy_MHz TSC_MHz     SMI  CPU%c1  CPU%c3  CPU%c6  CPU%c7 CoreTmp  PkgTmp Pkg%pc2 Pkg%pc3 Pkg%pc6 Pkg%pc7 Pkg%pc8 Pkg%pc9 Pk%pc10 PkgWatt CorWatt GFXWatt 
       3    0.30    1133    2300       0    0.53    0.03    0.00   99.14      40      40   18.66    0.28    0.90   78.52    0.00    0.00    0.00    0.97    0.01    0.00

With 3.19.0-15:
 Avg_MHz   %Busy Bzy_MHz TSC_MHz     SMI  CPU%c1  CPU%c3  CPU%c6  CPU%c7 CoreTmp  PkgTmp Pkg%pc2 Pkg%pc3 Pkg%pc6 Pkg%pc7 Pkg%pc8 Pkg%pc9 Pk%pc10 PkgWatt CorWatt GFXWatt
      13    0.64    1970    2300       0    0.89    0.12    0.01   98.35      46      46   18.25   78.78    0.00    0.00    0.00    0.00    0.00    2.28    0.12    0.00
  • 3.19 may be a bit new compared to 3.16, and newer kernels tend to have more unfixed bugs then older ones. – mikewhatever May 2 '15 at 18:53
  • 1
    Your problem is very interesting. In addition to what Mike said, it might also be worth trying a newer kernel, like 4.0.1 or 4.1RC1 to determine if the problem has been fixed, but the fix just hasn't been backported yet. Please add to your question which processor you are using, which CPU frequency scaling driver you are using and which frequency governor it is using. cat /proc/cpuinfo | grep "model name" cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_driver cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor – Doug Smythies May 2 '15 at 20:15
  • Thanks @DougSmythies Posted info as requested and will try new kernel soon. – niry May 3 '15 at 0:26
  • @DougSmythies I'm now using 4.0.1. It is not running as hot as 3.19 but also not as cold as 3.16. The case is bit warm and my calculation shows about 6 hours on battery. – niry May 3 '15 at 3:09
  • Can you use turbostat to determine if the power consumptions differences are processor related or graphics related? I would just run it for say 5 minutes: sudo turbostat -S sleep 300. Are you comfortable compiling the kernel? – Doug Smythies May 3 '15 at 4:08
3

This is a kernel bug reported here: https://bugzilla.kernel.org/show_bug.cgi?id=92111 (many thanks @DougSmythies)

Workaround: add acpi_osi= to the kernel cmdline in /etc/default/grub e.g.:

GRUB_CMDLINE_LINUX="hid_apple.iso_layout=0 elevator=cfq acpi_osi="

run sudo update-grub afterwards and reboot.

This will most likely disable thunderbolt.

  • 1
    Clarification: This will disable thunderbolt hot-plugging. If you first plug your thunderbolt device, and then turn on the computer, it will work as expected. – WhyNotHugo May 20 '15 at 17:23
  • Addendum: while my answer solved most of the battery consumption issues, there are still other issues. I'm currently unable to work on this and I switched back to MacOS and ubuntu under vmware. – niry Jul 4 '15 at 20:45
0

In my case, the issue 92111 caused the power usage increase.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.