After installing and updating, whenever I start Steam, it gives me the following error:

Running Steam on ubuntu 15.04 64-bit
STEAM_RUNTIME is enabled automatically
[2015-05-02 16:48:39] Startup - updater built Apr 13 2015 15:17:10
SteamUpdateUI: An X Error occurred
X Error of failed request:  BadValue (integer parameter out of range for operation)

I tried to find a solution to a similar error, but I was not able to find. Can anyone please help?

  • What exactly did you updated? Was it only Steam? Does it worked before? The integer parameter out of range for operation makes me think it is a Steam app bug. – Hi-Angel May 2 '15 at 16:46
  • I did the normal update after I installed, and then tried to install steam. Steam is installed but it doesn't start – QuietSwami May 4 '15 at 10:27
  • Is X Error of failed request… the last line of what the Steam prints before exit? Can you add to the post more lines if it isn't. – Hi-Angel May 4 '15 at 12:15
  • Yes, the terminal keeps running Steam, so I am able to add more lines – QuietSwami May 4 '15 at 16:34
  • 3
    I Had the same problem and this solution worked for me: askubuntu.com/questions/614422/… – user405943 May 4 '15 at 21:44
cd $HOME/.steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu
mv libstdc++.so.6 libstdc++.so.6.bak
cd $HOME/.steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu
mv libstdc++.so.6 libstdc++.so.6.bak

Type these into the terminal; it worked for me. Copied from this thread, posted by sejvenables, who copied it from someplace else.

  • 6
    This works, but reflects that the Steam installer needs to be updated as essentially a bundle library is too old. – Thorbjørn Ravn Andersen Apr 24 '16 at 18:41
  • 2
    I confirm that this works perfectly on Kubuntu 16.04! – Kunok Aug 20 '16 at 23:18
  • this same solution working in Debian 8 – Jasen Apr 17 '17 at 4:51

I had the same problem on Ubuntu 15.10, with an nvidia board. WPOH's solution made Steam work, but caused noticeable performance and mouse lag issues on some games.

Using the proprietary nvidia drivers fixed the problem without impacting the performance.

To revert those changes:

mv $HOME/.steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6{.bak,}
mv $HOME/.steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/libstdc++.so.6{.bak,}

And to install the updated proprietary nvidia drivers: open "Software & Updates", go to "Additional Drivers", select the latest binary nvidia driver (352.41 as of now) and then reboot the system. That did the trick for me :)

  • 2
    This is a great answer. I had to click through 3 links to get to the bug that led to @WPOH's answer and found the deletion of those two libraries to be unsatisfactory. It fixed the problem, but it doesn't sit well to just kill off a couple of files. Associating the correct drivers to the card in Software & Updates has me back up and running without monkeying in the CL with commands I'll probably forget that I issued and will never reverse. – JNevill Mar 19 '16 at 20:34

Based on Urgazhi's answer, you can do the following:

  • Open the file $HOME/.steam/steam.sh in a text editor
  • Add these as the first two lines of the file:

    export LD_PRELOAD='/usr/$LIB/libstdc++.so.6'
    export DISPLAY=:0
  • Save and launch steam normally.

  • 1
    or maybe setting an alias at ~/.bash_aliases like: alias steam="export LD_PRELOAD='/usr/$LIB/libstdc++.so.6'; export DISPLAY=:0; steam" – Iacchus Feb 6 '16 at 5:41
  • This works, but the original content of steam.sh seems to be restored when the Steam client exits (on Ubuntu 16.04 at least). – Tgr Sep 4 '16 at 8:30
  • @Tgr: If you can't set an alias as lacchus suggested above, try setting steam.sh to "read-only". Just make sure you revert to writable before accepting any updates to steam (probably won't see that file change, but better safe than sorry) – Brian Resnik Sep 5 '16 at 19:10

I was getting this problem because I had just installed the proprietary drivers but had not yet restarted my system. Silly I know, but hopefully this might help someone else.

Once I rebooted steam no longer had this problem for me.

export LD_PRELOAD='/usr/$LIB/libstdc++.so.6' #Export so all child    processes are affected as well
export DISPLAY=:0
steam -tcp

Easiest way to start steam would be to set the above shell script as an alias so when you call 'steam' in your cmd it will execute it.


i did have the same problem with the libgl errors the fix in the steam.sh worked great until steam updated. after 2 days i discovered that my pc wasn't booting in UEFI mode. so i booted up in UEFI mode and steam started up with no struggle at all. i hope that this story helped some of you :)

Not the answer you're looking for? Browse other questions tagged or ask your own question.