2

I recently installed EmulationStation and various emulators like KegaFusion, PCSX, PCSX2. All works fine, except for PCSX2.

All works fine, except for the audio on PCSX2. I followed several guides, but I didn't find any working solution.

I don't have enough reputation to post pictures, so I'll give you my setting by text (sorry about that). I'm using SPU2-X 2.0.0 [libspu2x-2.0.0] as main sound setting. In "configuration" i have Interpolation set to 4-Catmull-Rom(PS2-like/slow), I disabled effects processing. In "Output Settings" I set Module to 2-SDL Audio, and PortAudio API to 0-ALSA; Synchronization Mode to TimeStretch and latency to 40.

Here's also the ~/.config/PCSX2/inis/spu2-x.ini file, in case it helps:

[SOUNDTOUCH]
SequenceLengthMS=30
SeekWindowMS=20
OverlapMS=10
[MIXING]
Interpolation=4
Disable_Effects=1
DealiasFilter=0
FinalVolume=100
AdvancedVolumeControl=0
VolumeAdjustC(dB)=0
VolumeAdjustFL(dB)=0
VolumeAdjustFR(dB)=0
VolumeAdjustBL(dB)=0
VolumeAdjustBR(dB)=0
VolumeAdjustSL(dB)=0
VolumeAdjustSR(dB)=0
VolumeAdjustLFE(dB)=0
[OUTPUT]
Output_Module=SDLAudio
Latency=40
Synch_Mode=0
[PORTAUDIO]
HostApi=ALSA
Device=default
Wasapi_Exclusive_Mode=0
Minimal_Suggested_Latency=1
Manual_Suggested_Latency_MS=20
[DEBUG]
Global_Enable=0
Show_Messages=0
Show_Messages_Key_On_Off=0
Show_Messages_Voice_Off=0
Show_Messages_DMA_Transfer=0
Show_Messages_AutoDMA=0
Show_Messages_Overruns=0
Show_Messages_CacheStats=0
Log_Register_Access=0
Log_DMA_Transfers=0
Log_WAVE_Output=0
Dump_Info=0
Dump_Memory=0
Dump_Regs=0
Access_Log_Filename=SPU2Log.txt
WaveLog_Filename=SPU2log.wav
DMA4Log_Filename=SPU2dma4.dat
DMA7Log_Filename=SPU2dma7.dat
Info_Dump_Filename=SPU2Cores.txt
Mem_Dump_Filename=SPU2mem.dat
Reg_Dump_Filename=SPU2regs.dat
3
  • Don't put answers in questions. – JdeBP May 3 '15 at 15:15
  • How do I do whatever that guy said? Set the output device from the mixer? Don't understand. – user485710 Dec 24 '15 at 6:49
  • I was using Arch with KDE and the DE has a mixer where you can setup the audio output for every application running. – user404182 Dec 25 '15 at 9:23
3

Even if in the config file the Device parameter was set to default, you need to set the output device from the sound mixer. Yes, it was that easy.

2
  • How do I do whatever that guy said? Set the output device from the mixer? Don't understand. – user485710 Dec 24 '15 at 6:49
  • 1
    For future reference - going to the Sound section in Settings and clicking on Applications worked for me. – Florrie Oct 9 '17 at 21:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy