1

I upgraded to 15.04, now my GUI is blank when booting regular.

But I'm able to boot the GUI while selecting rescue mode.

apt-get update && apt-get-upgrade 

Says everything is up 2 date

I have a Nvidia GeForce GT 740

Help would be highly appreciated!

Update:

I was able to switch to onboad card and rerun the Nvidia installer, I also tried to enable the sddm service (as other recommended)

sudo systemctl enable sddm.service -f
sudo reboot

Also tried to boot without splash and quiet boot option

But now I'm sticking with a blank dark screen.

  • What did you mean by «blank screen»? Is it like this: you type a password in login manager, press enter, next the login manager disappears, but nothing appears intead? – Hi-Angel May 2 '15 at 17:07
  • No not even the login manager is comming up, screen stays at (Starting version 219) , but iam able to type some comments, and when i switch to onboard card i can see the console. – nfo May 2 '15 at 17:55
  • Found something, boot hangs at: A start job is running for udev Wait for Complete Device Initialization (1min 30s / 2min 58s) – nfo May 2 '15 at 18:19
  • Try this answer. Also, if that won't work, I'd try to wait a bit the hang, next press Alt+Shift+PrintScreen+r (it ought to take the keyboard to you if the problem with Xserver), switch to a virtual terminal with Ctrl+Alt+F1 and look at the /var/log/Xorg.0.log (you may want to post it here). To make sure that the «PrintScreen» combination would work, change the value in the /etc/sysctl.d/10-magic-sysrq.conf to 1. – Hi-Angel May 2 '15 at 18:52
0

I've got an nvidia card too and I've been working with Kubuntu 15.04 since Beta2. During the first weeks I had to use the nouveau drivers because it was impossible to use my nvidia optimus and change to nvidia mode without the blank screen. After trying a lot of things and ask for this issue in the Kubuntu's google+ community, finally I have it working. The steps I did:

-In Drivers configuration I selected the nouveau driver to leave the nvidia propietary driver unused. -Reboot -In Accounts configuration I marked autologin in my user -In SDDM advanced configuration I markedt autologin and select my user -These two steps are to avoid the SDDM login screen that causes the issue with the nvidia propietary driver. -sudo apt-get remove nvidia* (to erase all the files of my nvidia-340 version) -sudo apt-get install nvidia-346 nvidia-prime nvidia-settings -Reboot -After that, my laptop started up and go into the desktop without stop in the SDDM login screen. I searched for the nvidia-settings app in the K-menu and I confirmed that my nvidia was working in nvidia mode. I tested it with glxgears and I got 1700FPS when it was 50FPS in intel mode ou with the nouveau driver.

Hope it helps yo

0

OP has solved the problem, taken from his question:

I added nomodeset to my grub booting parameter, now it works again.

thanks for your comments!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.