2

I have installed Ubuntu 15.04 a few days ago after some years of Archlinux experience.

I have a few MKV video files and for some reason I am not able to switch the audio language in the menu bar at the top of the screen (it's called global menu, isn't it?). However switching the language via right click in the video screen is possible! I have the same problem with the selection of the subtitles. In the menu bar at the top, the menu item is disabled and no different subtitles are listed at the menu. In the right click menu of the video the selection of the subtitle is possible.

Is this a bug or is something wrong with my installation? Can anybody suggest a workaround for this problem?

I have already searched for a bug report, but there seems nothing about it at Launchpad...

Installed VLC version: 2.2.0-1

EDIT: Here is a screenshot of my VLC -> Audio Menu. As you can see, the "Audio Track" menu is completely disabled. Despite the fact that this video has multiple audio tracks available!

EDIT2: I just discovered that the totem video player has a similar problem for me. If I open the video file with totem the Language Menu Item is enabled, but there are no languages shown in the menu! (See 2nd screenshoot below).

VLC Screenshot Screenshoot of VLC Menu Totem/Video Screenshot Screenshoot of Totem Menu

2
  • I am having the same problem too..can't see menu bar at all, including close, minimize and maximize. The only way for me to close is Alt F4. I think this is a bug in VLC becuase I had the problem in 14.04 also. – Ron May 2 '15 at 13:13
  • There may be a bug report on it in the VLC forums. Search there for VLC specific issues. If multiple Video player programs have the same issue then it could be OS related. – Jon S. May 2 '15 at 13:14
0

Okey, I did some research and managed to get menus back in VLC! In summary you need to reset the preferences. You can try these commands in terminal:

rm -r ~/.config/vlc
rm -r ~/.cache/vlc
vlc --reset-config

This is how it looks now!

enter image description here

2
  • Hmm, I am not sure if we are talking about the same problem. My problem is not that the menu bar isn't there. My problem is, that some menu items in the menu seems not to be updated and enabled after I open video... – flammi88 May 2 '15 at 15:11
  • Anyway, the solution above does not work for me ;-) – flammi88 May 2 '15 at 15:12
0

It seems that this is a bug/regression in 15.04 that is not fixed until now. I found a bug report at launchpad that describes my problem quiet well.

It seems that there is a problem with the unity appmenu that appeared in 15.04.

EDIT: A possible workaround for VLC is to remove appmenu-qt from the system. You have to execute the following command in a terminal window:

sudo apt-get remove appmenu-qt

This brings the menu of VLC back into the window (disabling the global menu for it). Now it's possible to select audio/track subtitle again!

Anyway, thanks for your help!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.