0

I have a following problem. When using

\curl -L https://get.rvm.io | bash -s stable --ruby 

to download rvm, I get error:

curl: (1) Protocol https not supported or disabled in libcurl

I'm unsure how to fix it, any thoughts? If you need more information, I'd be more than happy to provide.

@Edit: More information

apt-cache policy curl 

curl: Installed: 7.37.1-1ubuntu3.4 Candidate: 7.37.1-1ubuntu3.4 
Version table: *** 7.37.1-1ubuntu3.4 0 500 
http://pl.archive.ubuntu.com/ubuntu/ utopic-updates/main amd64 
Packages 500 http://security.ubuntu.com/ubuntu/ utopic-security/main amd64 
Packages 100 /var/lib/dpkg/status 7.37.1-1ubuntu3 0 
500 http://pl.archive.ubuntu.com/ubuntu/ utopic/main amd64 Packages

And

which curl 

/usr/local/bin/curl
  • How did you install curl? Are libcurl4-gnutls-dev and libcurl3-gnutls installed? – muru May 2 '15 at 11:53
  • Are you required to use curl? perhaps you could try wget -O- instead? – steeldriver May 2 '15 at 11:56
  • Unfortunately, curl is a must. @muru Now that I think about it, it might be because I installed curl7.30 when I've been doing some cpp programming, maybe it's because of this? Other than that curl was already installed on my system. How do I check for libcurl4-gnutls-dev and libcurl3-gnutls? – Krzysztof Piszko May 2 '15 at 11:58
  • Never mind, the default curl has SSL support compiled in - those packages are only need for developing (or other applications). Check which curl you are running (which curl), and if you have Ubuntu's curl installed (apt-cache policy curl). – muru May 2 '15 at 12:03
  • 1
    @muru apt-cache policy curl curl: Installed: 7.37.1-1ubuntu3.4 Candidate: 7.37.1-1ubuntu3.4 Version table: *** 7.37.1-1ubuntu3.4 0 500 http://pl.archive.ubuntu.com/ubuntu/ utopic-updates/main amd64 Packages 500 http://security.ubuntu.com/ubuntu/ utopic-security/main amd64 Packages 100 /var/lib/dpkg/status 7.37.1-1ubuntu3 0 500 http://pl.archive.ubuntu.com/ubuntu/ utopic/main amd64 Packages And which curl out: /usr/local/bin/curl – Krzysztof Piszko May 2 '15 at 12:13
0

You have Ubuntu's curl installed, and another curl installed in /usr/local. Either specify the full path to get Ubuntu's curl (/usr/bin/curl), or change the PATH for your script to skip /usr/local/bin.

  • I've tried both options, still getting the same error. Going to try to remove curl and install it again. – Krzysztof Piszko May 2 '15 at 12:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.