When I first boot the system everything works fine. But then something happens (not sure what triggers it) and many programs start scrolling just by moving the mouse over the window. So far I see this happens in Nautilus, Document Reader, Archive Manager, Ubuntu Software Center, Meld, and System Monitor (what do they all have in common, GTK?). It does NOT happen in web browsers, thunderbird, programs using Mono, Java, etc, for some reason.

To be more specific of the issue: if the mouse starting position is over a document in Document Reader, for example, and then I move the mouse via touchpad, it'll scroll the document like an anchor, where the position of the mouse over the document doesn't change (yet it scrolls). I have already tried disabling "two finger scroll", "disable while typing", and the "tap to click" options, but they made no difference (after the glitchiness starts).

The other odd case is that in Nautilus, if the mouse starting position is over a file or directory, it sometimes selects it instead of scrolling. Single-clicking a directory will open the directory (so the initial touch acts like a clicks, and letting go acts as the second click).

The only thing I can do to temporarily fix the problem is restart the computer. There are no issues when using a mouse.

Update 2015/05/03: I see how to reproduce it now. It appears to be a glitchy two-finger scroll issue. If you scroll any window with two fingers a lot, eventually it'll start causing this problem. Try various actions with two fingers, like "clicking" with two fingers, or scrolling in various directions quickly, etc, and it will start happening. It's interesting that it only happens in certain programs and not in others, which makes me wonder whether it is really a trackpad issue or some framework's issue. I can confirm that this is happening on the 15.04 Live CD, so this happens out of the box. If anyone has any clues, please update me!

The only work-around for this issue is to disable two-finger scroll (if it's already glitchy you'll need to restart). Not sure if it matters, but I'm using the Dell XPS 13 2015 9343.

Update 2015/05/05: Apparently this bug can still happen even with two-finger scroll off, though it's more rare. Again, only certain programs have the issue, so it's hard to tell if it's a touchpad issue or something else.

Update 2015/05/12: I have filed a bug report here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1454473

Blacklisting the psmouse improves the situation but xchat gnome is still having issues.

I followed instructions on https://github.com/mpalourdio/xps13

Check that your BIOS is version A03 or later, and touchpad firmware is up to date Touchpad firmware A00.

blacklist psmouse driver so that the trackpad uses i2c instead. Make sure there is no PS/2 in the output of xinput -list.

I noticed that xchat-gnome seems to be ignoring the touch-to-click setting and some other applications too (like VLC, but only the preference window).

In Xorg.log I see this error when the touchpad goes nuts:

(EE) [dix] DLL0665:01 06CB:76AD UNKNOWN: unable to find touch point 0

The only way I have to solve temporarily the issue is to disable the trackpad completely from the Settings panel and enable it again. Make sure you have an external mouse attached.

  • Would you mind adding specific instructions instead of just linking? I'd appreciate it. – Blossoming_Flower May 6 '15 at 0:29
  • I followed the instructions here but unfortunately the problem persists. – Blossoming_Flower May 6 '15 at 2:12
  • I have not. Not exactly sure where to file it, and I don't have exact steps to reproduce the issue. What would you suggest? – Blossoming_Flower May 8 '15 at 16:35
  • Just noticed your edit. xinput -list shows: Virtual core pointer id=2 [master pointer (3)] ⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)] ⎜ ↳ DLL0665:01 06CB:76AD UNKNOWN id=11 [slave pointer (2)] ⎜ ↳ 2.4G KB 2.4G Mouse id=16 [slave pointer (2)]. As I said, blacklisting psmouse didn't help. I have BIOS A03 already. How do I check the touchpad firmware version and update it in Ubuntu? – Blossoming_Flower May 8 '15 at 16:40
  • 1
    I have the same issue. It may be a kernel bug, but I've noticed there's only a problem in gtk apps. In chrome (which I think runs under QT), there's no such issue. – Tom R May 20 '15 at 18:52

Having the same issue on my Dell XPS 13 9343. Using the configuration that Stefano Maffulli suggested in the above comments seems to be working so far. It was in the glitchy state when ran the command, so its possible just updating the synclient settings might have kicked it out of some bad mode. So it might be the case that any change in the synclient settings makes the mode reset.

gist.github.com/anonymous/c217e67ea93a51dbc5d6

Compared to the defaults it made the following changes

- VertScrollDelta=100
- HorizScrollDelta=100
- TapButton2=2
- TapButton3=3
- ClickFinger2=2
- CircularScrollDelta=0.15
- CoastingSpeed=0

If its more than just updating the settings that caused the fix, it would have to come down to one of the settings listed above.

Hope that helps

I found that disabling the touchpad and re-enabling it helped.

In the Mouse & Touchpad Ubuntu system settings, turn it off touchpad, then use [Tab] and [Enter] keys to navigate and turn back on the touchpad setting.

Credit from: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/1454473/comments/9

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.