4

When I start Gimp from the terminal it won't launch. I get the following error message:

(gimp:17589): Gtk-WARNING **: Attempting to read the recently used
resources file at `/home/richard/.local/share/recently-used.xbel', but
the parser failed: Failed to open file
'/home/richard/.local/share/recently-used.xbel': Permission denied.

Not sure how to set the permissions for this.

7
  • Issue this command getfacl /home/richard/.local/share/recently-used.xbel and update question with this info May 1 '15 at 19:27
  • I issued the command: May 1 '15 at 19:48
  • I issued the command getfacl /home/richard/.local/share/recently-used.xbel but am unsure about what to do next. May 1 '15 at 19:49
  • Man, please update question with output of that command. Next, I will think that we can do with it. May 1 '15 at 19:54
  • Sorry. getfacl: Removing leading '/' from absolute path names # file: home/richard/.local/share/recently-used.xbel # owner: root # group: root user::rw- group::--- other::--- May 1 '15 at 20:00
2

Issue this command to fix GIMP:

sudo chown richard:richard /home/richard/.local/share/recently-used.xbel

Try to run GIMP or post me result.

EDIT:

Revert it back in case of fail:

sudo chown root:root /home/richard/.local/share/recently-used.xbel

and try to set new permissions

sudo chmod 700 /home/richard/.local/share/recently-used.xbel

UPDATE:

Setting /home/richard/.local/share/recently-used.xbel owner to richard:richard and 0600 permission together with removing old GIMP configs probably solved problem.

15
  • I issued the command and tried to run GIMP but it still doesn't launch. It starts and shows up in the launcher but doesn't open. I didn't get any error messages at all. May 1 '15 at 20:08
  • updated answer, please issue one more time and let me know results. May 1 '15 at 20:12
  • Same result. It starts to load and shows up in the launcher but does not open. May 1 '15 at 20:14
  • no error messages at all. May 1 '15 at 20:15
  • ok, please try to rename this file. sudo mv /home/richard/.local/share/recently-used.xbel /home/richard/.local/share/recently-used.xbel.backup and run gimp one more time. Please let me know results May 1 '15 at 20:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.