0

Short version: where did the Reinstall without erasing option go?

A friend's machine has been running 14.04 for almost a year. Some time in the last week or so the keyboard and mouse stopped working. I have tried both PS/2 and USB types and neither work with his current setup. However, it's clearly not a hardware issue because if I put in a Live CD everything works great.

I tried using the "Install Ubuntu" icon on the desktop top, but the only options it offers appear to be Erase the existing install, including /home and all of the installed software.

I have found references on the net (e.g. here) that show pictures where the first option is to reinstall and preserve home directories and installed programs, but an ISO downloaded this morning does not give me that option.

I'm sure I'm missing something obvious.

  • Welcome to Ask Ubuntu! ;-) Did you try to press the [shift] key while booting and get to the recovery menu? If yes, are the home and system directories on different partitions? Also: does this happen in the guest session as well? – Fabby May 1 '15 at 23:05
  • Uhm, Thanks, no, no, and I don't know (I didn't even know there was a guest account and cannot find it mentioned in the /etc/passwd file). I'm currently backing up /home and /etc prior to using the Something Else option and installing over the current install (without erasing). I will definitely first try the things you suggest since they all sound a good deal less destructive than my "plan". I did find some earlier kernels (13.xx) and they exhibited the same behavior for this user. – Peter Rowell May 1 '15 at 23:34
  • What version and flavour of Ubuntu are you running? – Fabby May 2 '15 at 11:18
  • So ... you're saying my post is a dupe of another post that went up a month after I posted. Hmmm ... I'm going to ask for a ruling by the Time Lords on that one. And that post was by someone moving from a different distro (Mageia) to Ubuntu/Debian, and the answer was to do a bunch of stuff manually. OK, although I knew how to do it that way back in the '80's. (Don't be fooled by the 104 AskUbuntu points.) And all of this is from 4 years ago about a release that happened almost 5 years ago. Got it. – Peter Rowell Feb 14 '19 at 0:28

Browse other questions tagged or ask your own question.