When trying to burn a DVD it sometimes happens that growisofs will fail with:

$ sudo growisofs -speed=8 -dvd-compat  -Z /dev/scd0 -J -r .
Executing 'genisoimage -J -r . | builtin_dd of=/dev/scd0 obs=32k seek=0'
I: -input-charset not specified, using utf-8 (detected in locale settings)
0.23% done, estimate finish Fri Sep 16 14:49:33 2011
0.46% done, estimate finish Fri Sep 16 14:49:33 2011
0.69% done, estimate finish Fri Sep 16 14:49:33 2011
:-( unable to O_EXCL /dev/scd0: someone was in time to remount?

This only seems to happens when burning multiple DVD's in a row and I think it happens when I eject an automounted disc without manually unmounting it first, which implies that something is keeping the drive busy, lsof and fuser however fail to find a process still accessing the drive. Rebooting makes the problem go away.

How can I find out what process is causing this issue?


This can happen if your /etc/fstab has the following line for your cdrom:

/dev/cdrom /media/cdrom auto rw,noauto,user,exec 0 0

Change it to

/dev/cdrom /media/cdrom iso9660 rw,noauto,user,exec 0 0

, reboot and try if it still happens.



I have been running into issue now again a few times and I am reasonably confident that it is really nothing more then having an shell open that is still in /cdrom/ and thus prevents a proper unmounting of the drive.

Still no idea on how to find the trouble causing shell with lsof or fuser, but there is another way that should work:

sudo ls -l /proc/*/cwd  | grep -i cdrom
  • had this issue too, with 12.04 LTS, default desktop GUI setup (running from the livecd on a USB stick, actually). Hit the eject button on the drive to umount and open the tray,but now growisofs can't open /dev/sr0 with O_EXCL. I guess it didn't really unmount? But there's nothing about it still in /proc/mounts, and no processes with a cwd in /media or anything. I can mount and unmount burned discs with no complaints or effects on the problem. Is there a bug open for this on Launchpad? – Peter Cordes Dec 27 '12 at 5:01
  • update: actually some mounting and careful unmounting do appear to have solved it. /proc/<pid>/cwd doesn't show the working directory of a process still CDed to a force-unmounted filesystem, so I did find a shell that might have been CDed to a CD while I was trying to burn the first time – Peter Cordes Dec 27 '12 at 5:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.