0

I have turned off power management for my wireless. I did that in /etc/pm/power.d/wireless.

When I try to connect to a network, the power management turns back on. So the connection fails.

I try:

sudo iwconfig wlan0 power off

The power management is then off, but when I connect it is turned back on.

I added a service as detailed here, it is now initially off. When I try to connect, the power management turns on again.

Output of lshw -C network:

*-network
   description: Wireless interface
   product: Wireless 7260
   vendor: Intel Corporation
   physical id: 0
   bus info: pci@0000:02:00.0
   logical name: wlan0
   version: 6b
   serial: <redacted>
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=iwlwifi driverversion=3.19.0-15-generic firmware=25.15.12.0 latency=0 link=no multicast=yes wireless=IEEE 802.11abgn
   resources: irq:43 memory:f0400000-f0401fff
*-network DISABLED
   description: Ethernet interface
   physical id: 1
   logical name: virbr0-nic
   serial: <redacted>
   size: 10Mbit/s
   capabilities: ethernet physical
   configuration: autonegotiation=off broadcast=yes driver=tun driverversion=1.6 duplex=full link=no multicast=yes port=twisted pair speed=10Mbit/s

What is happening here? Can I try anything else?

  • What is the driver in question? lshw -C network Some drivers allow manipulating power management. – chili555 May 1 '15 at 11:51
  • @chili555 it worked before so I don't think that is the case. But the question now has the output of lshw -C network. – Thijs Wouters May 1 '15 at 12:01
  • I'd guess that power management daemon isn't working with 15.04 or pm-utils isn't working somehow. As a workaround, you can add sudo iwconfig wlan0 power off as Exec= line into .desktop in your ~/.config/autostart, to do it on every login – Sergiy Kolodyazhnyy May 1 '15 at 15:42
1

Hooks in /etc/pm/ are ignored in Ubuntu 15.04. Instead you have to create systemd services and enable them.

Although first try adding

sleep 10
iwconfig wlan1 power off
exit 0

to your /etc/rc.local file. This should turn of power management at boot and might help with the connection. To permanently disable the power management look here.

More info about hooks in /etc/pm not working anymore here. To create systemd services have a look at ArchWiki.

Hope this helps.

| improve this answer | |
  • I tried it, it did not work. Now the power management is initially off. – Thijs Wouters May 1 '15 at 11:42
  • For a robust solution see here – spinxz Jun 19 '15 at 14:05
0

This had nothing to do with Ubuntu.

My ISP, which also handles my wifi, blocked it because I did not pay in time.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.