0

I just installed xubuntu 14.04 on an asus gl771j laptop. It comes with an integrated intel video card and another nvidia 860m video card. I open the additional drivers setting window and I get "no additional drivers available" enter image description here

I got as far as getting this information, but that's it

sudo lshw -c video
  *-display UNCLAIMED     
       description: 3D controller
       product: GM107M [GeForce GTX 860M]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a2
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuration: latency=0
       resources: memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:f7000000-f707ffff
  *-display
       description: VGA compatible controller
       product: 4th Gen Core Processor Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 06
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:53 memory:f7400000-f77fffff memory:d0000000-dfffffff ioport:f000(size=64)

How can I install the nvidia drivers?

Thanks in advance.

  • Have you tried disabeling the onboard graphics card in the bios/uefi? – Pabi May 1 '15 at 0:47
  • Like @Pabi said, you probably need to change discrete graphics to be the default over integrated. I'm pretty sure Ubuntu doesn't do switchable graphics, so hopefully you have this option. – TheWanderer May 1 '15 at 1:06
  • if ubuntu doesn't do switchable graphics, is there a distro that does? – Gringo May 1 '15 at 1:18
  • This problem should be resolveable in ubuntu, just let us know if there is no option to turn it off. – Pabi May 1 '15 at 1:31
  • no, i don't see a option in bios setup to turn the intel card off. – Gringo May 1 '15 at 2:36
0

Ok,

First I thought maybe the problem was the Intel card driver. So I downloaded it from them, but then I saw that 14.04 was not a supported distro.

So I've installed 15.04 (even if I prefer LTS) and now I see this: enter image description here I haven't restarted yet :P

  • seems to have worked! – Gringo May 1 '15 at 2:59

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.