6

I upgraded Ubuntu 14.10 to 15.04 and ALL my Keyboard shortcuts are broken.

I mean shortcuts like ctrl+alt+t, fn+any arrows.

I checked keyboard settings and all is turned on.

Any idea how to fix it ?

Am using notebook y50-70.

  • Do they start if you run gnome-settings-daemon command ? – Sergiy Kolodyazhnyy May 1 '15 at 3:40
  • Hell yeach. Its working :D But only if this command is running :P – Pawliko May 1 '15 at 9:49
  • Good ! Add this command to Startup Applications or create a .desktop file for this job in /home/yourusername/.config/autostart. If adding to Startup Applications doesn't do it sometimes , go with second option - that always works. For more info just look up how to create .desktop file. I'm kinda in a rush but I will come back and post this as an answer later – Sergiy Kolodyazhnyy May 1 '15 at 12:22
  • Thats work ! THX so much :P – Pawliko May 1 '15 at 12:54
  • No problem buddy , I'll post an answer later, so accep and upvote. That's the best way to thank people on this site – Sergiy Kolodyazhnyy May 1 '15 at 13:21
6

Your gnome-settings-daemon isn't starting on boot, for some reason. The workaround to that is to add gnome-settings-daemon to Startup Applications or add it as a .desktop entry, into /home/yourusername/.config/autostart/ directory. The .desktop entry could be named gnome-settings-daemon.desktop and look something like this:

[Desktop Entry]
Type=Application
Exec=gnome-settings-daemon
Hidden=false
Name=gnome-setting-daemon

This is my guess on why that daemon isn't starting: Ubuntu 15.04 , from what I've heard, has switched for different system for starting processes at boot - there used to be upstart and 14.04 (which is what I use) has that. Meanwhile 15.04 uses systemd . My guess is that this transition has broke some things, but hopefully by the time we get to next LTS release, everything will be fixed

  • 3
    Sadly this doesn't appear to work in 16.04. Installing and attempting to run gnome-settings-daemon in 16.04 results in the error ** (gnome-settings-daemon:4159): WARNING **: Name taken or bus went away - shutting down – Elder Geek Aug 19 '16 at 16:06
  • What is the command for Fedora 26? – codezombie Oct 14 '17 at 3:18
2

Just do this via terminal, is a bug.

sudo apt-get remove appmenu-qt5
sudo apt-get remove --auto-remove appmenu-qt5

then log out and probe... this works for latex

0

In my case the gnome-settings-daemon process was hang:

0 D alex   3798  3587  0  80   0 - 472136 rpc_wa Apr18 tty2    00:00:17 /usr/libexec/gnome-settings-daemon

I just killed it and it reloads automatically. After that everything is working properly.

-3

Go to your home directory.

$cd ~
$ls -a

You can see .gconf directory. If you remove this directory you will come back to your default desktop settings.

rm -rf .gconf/

Restart

It is an easier way of resetting back to your default desktop configuration. I hope this works for you.

  • 1
    That will delete a lot of other settings and is a way to agressive solution. Don't do it! – Karl Richter Aug 12 '15 at 10:11
  • GConf doesn't delete any important configuration, it only changes the desktop environment configuration. As per the definition, GConf is a system for storing application preferences. It is intended for user preferences; not configuration of something like Apache, or arbitrary data storage. Yes, it is an aggressive step if you have done a lot of desktop configuration changes but you might not know which thing you have messed up, so becomes very difficult to recover. It is an easier way of resetting back to your default desktop configuration. – Abhishek Singh Aug 17 '15 at 4:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.