3

I clicked the upgrade button from version 14.10 to 15.04. sweethome3d and EasyTether do not work. I went to Ubuntu Software Center uninstalled sweethome3d and reinstalled and it still will not start.

I also got the latest copy of EasyTether (easytether_0.7.4-1_amd64.deb) reinstalled it and it connects but it will not connect to the internet. I have a dual boot to 14.10 and both these programs work fine on 14.10 with the same hardware. Which is HP TouchSmart 14 Sleekbook and using HTC Droid DNA for the easyTether connection.

  • sweethome3d does not work here either. You might want to file a bug report. You better use the version from website author, version 4.6 which is working. No idea about easytether – solsTiCe Apr 30 '15 at 19:39
  • I concur, easytether is not working on 15.04 for me, either. – karlgrz May 1 '15 at 22:48
  • package intended for Mint 17.1 (v.0.8.3-1) and install it what are you talking about? easytether or network manager? easytether only has 1 download and its 0.8.4-1 and its the same one for mint 13. explain your answer – user116272 May 11 '15 at 4:25
  • Sweet Home 3D doesnt seem to work on ubuntu 15.04 in unity but runs flawlessly in Cinnamon. When using unity, I have to run it via the terminal. – user444276 Aug 28 '15 at 11:32
0

For easytether, autoconfig does not work because they upgraded network-manager.

Configure the network interface manually with dhclient, there should be instructions in the terminal when you run easytether.

0

Easytether

I had the same problem with easytether, and running the recommended dhclient command did not correct the issue. My solution was to download instead the package intended for Mint 17.1 (v.0.8.3-1) and install it. From there, I ran from the terminal:

nohup sudo easytether-usb &
sudo dhclient tap-easytether

Which allowed me to connect, albeit easytether is no longer showing up as a network connection as it did when I ran Ubuntu 14.X. I haven't had much opportunity to test the stability or security of this - I frankly have a limited knowledge of the differences between Ubuntu and Mint, but I haven't had any issues so far.

Sweethome3d

I was able to download the newest version of Sweethome3d (v.4.6) from the download page and it ran without issue on my Ubuntu 15.04 installation. I then tried downloading and running the version from the Ubuntu Software Center (v.4.5+dfsg-3) and was unable to get it to run (it just throws a LOT of exceptions). I conclude, therefore, the issue lies in the version provided in the Ubuntu Software Center, which simply isn't compatible with 15.04.

0

This problem with SweetHome3D, which I also experience, may caused by the 'systemd' switchover in Ubuntu 15.04. A similar issue has been found with ESET Nod32 Antivirus and is solved for that specific app here...

http://kb.eset.com/esetkb/index?page=content&id=SOLN3723&locale=en_US

That worked for me with ESET but to compose an analogous script to put into /lib/systemd/system for SweetHome3D is well above my paygrade. Hopefully, if the solution does lie in that direction, someone may oblige?

EDIT - OK, so I thought I'd try opening Ubuntu 15.04 in Advanced Mode - 'Upstart' option. Because if the recent systemd switchover is the main cause, then this should work round the problem. But it still wouldn't launch. So back to normal boot and Terminal: sudo sweethome3d . Then it launched, after a delay and some comment about creating a particular folder for Java.

I haven't tried actually using it yet. So, who knows...

0

Latest version of easytether apk latest version easytether deb .. Use steps that was posted above DNS does not get set so you must manually enter a DNS in /etc/dhcp/dhclient.conf .. Restart

0

This worked with easytether PRO on a Dell XPS 12 laptop and a fresh install of 15.04

1) Open the dhclient configuration file for editing

sudo gedit /etc/dhcp/dhclient.conf

2)Add the easytether-tap hard coded DNS

prepend domain-name-servers 192.168.117.1/24

save and close file, restart machine

3)Start easytether service

sudo easytether-bluetooth xx:xx:xx:xx:xx:xx

xx:xx:xx:xx:xx:xx being the bluetooth device address (which can be found through the bluetooth settings on the panel) or if your using a usb cable

sudo easytether-usb

4)Once connected, configure the network interface.

sudo dhclient easytether-tap

5)Test connection in your browser

*Note: Easytether is my only internet connection so I am unable to verify that the change to the dhclient.conf file doesn't effect the operation of other network setups in use.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.