2

A tutorial called Quickly Setting up Awesome with Gnome describes the process of setting up Awesome window manager in such a way as to retain some features and advantages of GNOME. I figured MATE desktop is a modern version of GNOME 2, so I am trying to set up Awesome with MATE, but to no effect.

I am trying to use the part of the tutorial that describes steps for GNOME <2, namely:

gconftool-2 --type bool --set /apps/nautilus/preferences/show_desktop false

and

gconftool-2 --type string --set /desktop/gnome/applications/window_manager/current /usr/bin/awesome

or

gconftool-2 --type string --set /desktop/gnome/applications/window_manager/current /usr/bin/awesome

then writing

[Desktop Entry]
Version=1.0
Type=Application
Name=Awesome
Comment=The awesome launcher!
TryExec=awesome
Exec=awesome

to ~/.local/share/applications/awesome.desktop.

There's no effect. Here's what another tutorial on the topic says to do:

Create the following file at /usr/share/xsessions/Xsession.desktop:

[Desktop Entry]
Encoding=UTF-8
Name=Awesome + MATE
Comment=Awesome + MATE
Exec=/etc/X11/Xsession

Create the following file at ~/.xsession

#!/bin/sh
mate-session &
awesome

Sign out, then choose "Awesome + Mate" clicking on the little cog in the upper right corner.

Remove the MATE panel at the bottom, remove the notification area from the one at the top, go to "Properties", and uncheck "Expand".

Disable the desktop icons in Control Panel -> Look and Feel -> MATE Tweaks

(where is Control Panel?)

Anyway, this still doesn't quite work. Firstly, I install MATE on Ubuntu with

sudo apt install mate-desktop

But the option to select MATE when clicking at the cog in the greeter doesn't appear until I install

sudo apt install mate-session-manager

as well (should I install something else?) Now, when I do everything above, when I choose "Awesome + Mate" at the greeter cog, the awesome desktop briefly flashes, to be replaced with MATE completely. Now, when I log off in MATE, I am back in awesome. When I quit awesome, I'm back at the greeter. Not what I expected when I opted for "Awesome + Mate" experience.

What should I do?

  • The supposed link to tutorial actually goes to Google search, which as of now doesn't yield the tutorial. Does anyone have the actual tutorial? I don't know what I was thinking. – Nickolai Leschov Jun 13 at 4:17
  • Anyway, the tutorial didn't work for me. I found another one which I'm incorporating into the question, and it didn't work as well. So I'm starting a bounty. – Nickolai Leschov Jun 13 at 4:20
2

The tutorial you mention didn't work for me at first.

First, the file in ~/.local/share/applications/awesome.desktop is not recognized; you should put it in /usr/share/xsessions

Second, with this desktop entry you would only start awesome, but you may also want to have gnome-session, mate-session or xfce4-session (or whatever your session manager is, as long as its loads the Gtk theme, Wifi applet, sound manager, etc.) To do this, create a desktop entry that just calls Xsession:

$ cat /usr/share/xsessions/Xsession.desktop 
[Desktop Entry]
Encoding=UTF-8
Name=Xsession
Comment=Xsession
Exec=/etc/X11/Xsession

Then write a .xsession file in your user directory:

$ cat ~/.xsession
#!/bin/sh
xfce4-session &
awesome

Finally, select the "Xsession" entry in lightdm and you should see awesome fire up with the rest of your session. (Tested on Xubuntu with xfce4-session and Debian Wheezy with mate-session.)

0

I've just installed it successfully in Ubuntu Mate 15.04.

All I did was:

sudo apt-get install awesome

After I logged out, I could choose awesome as a WM in to top right corner of the log-in screen:

http://i.imgur.com/9E6ofNj.jpg

  • 2
    This isn't exactly what this thread is about. The problem is getting awesome working within Mate. – senorsmile Nov 16 '17 at 18:17
0

After finding this thread today trying to get something similar set up in Ubuntu MATE 16.04 LTS Beta 2, I found that the following worked for me:

from https://wiki.debian.org/JosueAbarca

# To use awesome instead of marco
gsettings set org.mate.session.required-components windowmanager 'awesome'
# You can verify it with:
gsettings get org.mate.session.required-components windowmanager
# To return to the default window manager (marco) run:
gsettings reset org.mate.session.required-components windowmanager
# To disable the desktop icons provided by caja
gsettings set org.mate.background show-desktop-icons false

EDIT: I had previously thought the above was all I needed, but after trying to set it up on a fresh install I was having issues getting awesome to launch.

Setting the string in gsettings tells MATE which application to launch as a window manager, but this doesn't seem to be the same as specifying an executable to launch.

After placing the following in /usr/share/mate/applications/awesome.desktop, awesome launches with MATE with the above gsettings set (I used one of the other files as a template, some of these lines may be unnecessary)

[Desktop Entry]
Type=Application
Name=awesome
Exec=awesome
NoDisplay=true
# name of loadable control center module
X-MATE-WMSettingsModule=awesome
# name we put on the WM spec check window
X-MATE-WMName=awesome
# back compat only
X-MateWMSettingsLibrary=awesome
X-MATE-Bugzilla-Bugzilla=MATE
X-MATE-Bugzilla-Product=awesome
X-MATE-Bugzilla-Component=general
X-MATE-Autostart-Phase=WindowManager
X-MATE-Provides=windowmanager
X-MATE-Autostart-Notify=true

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.