I open the "terminal" using the link I have on my unity bar.

If I type: ls -l

I see files.

If I type: find or any other commands, the terminal closes immediately.

This happens after I did an apt-get update and apt-get upgrade

EDIT: must be something else now since Google Chrome and Skype now won't open.

I get:

$ /usr/bin/google-chrome

[3903:3903:0430/105632:ERROR:process_singleton_posix.cc(975)] Failed to create socket directory.
[3903:3903:0430/105632:ERROR:chrome_browser_main.cc(1213)] Failed to create a ProcessSingleton for your profile directory. This means that running multiple instances would start multiple browser processes rather than opening a new window in the existing process. Aborting now to avoid profile corruption.
  • Can you see any logs for wired behaviour of terminal on /var/log directory ? – Mitesh Shah Apr 30 '15 at 17:15
  • @MiteshShah which log file? I have a lot of them – Pat R Ellery Apr 30 '15 at 17:21
  • Press ctrl+alt+f2 then login in to system and run following command tail -f /var/log/* Above command read all the logs file now go back to GUI using ctrl+alt+f7 or f8 and start your terminal when its crash check CLI tail command output – Mitesh Shah Apr 30 '15 at 17:24
  • when I type both true or false, nothing happends, the terminal is still open – Pat R Ellery Apr 30 '15 at 17:55
  • run this command and correct your pesrmissons: sudo chown -R "$USER":"$USER" "$HOME" and give me a comment with @A.B. – A.B. May 10 '15 at 9:44
up vote 5 down vote accepted

The issue is your program don't have access to write to the temporary folder. ls works because it reads the current folder without "saving" anything. find on the other hand "caches" data to the temp folder. If he can't it crash!

Check your permissions on the /tmp folder.

ls -la /tmp

You should get something like this.

bookofzeus@askubuntu:~$ ls -la /tmp
total 60
drwxrwxrwt 12 root    root    12288 May  9 14:39 .

Now, check the permissions on the "." It should be writable by everyone.

If not, then that's your problem.

Change it to 1777 (sudo chmod 1777)

  • no you need to use 1777 to get the sticky bit – solsTiCe May 9 '15 at 22:51
  • 1
    That's not right. I have temporary set my access rigths for /tmp: d--------- 17 root root 16384 Mai 10 11:38 . and my terminal works, also with find. – A.B. May 10 '15 at 9:39

It looks like you have the e option set.

It might have been set in ~/.bashrc: browse to ~/ with nautilus and hit Ctrl+H to show hidden files, then open ~/.bashrc with gedit and remove this line, if not needed:

set -e
  • I have nothing using the "set" command – Pat R Ellery Apr 30 '15 at 17:26
  • @PatREllery It might have been set somewhere else, run echo $- and see if the e option is set – kos Apr 30 '15 at 17:32
  • it shows: himBH – Pat R Ellery Apr 30 '15 at 17:55

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.